Author Topic: Unable to get a lab software to Zentyal domain  (Read 330 times)

chinmaycomp

  • Zen Apprentice
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Unable to get a lab software to Zentyal domain
« on: November 27, 2020, 02:43:27 pm »
We have recently started testing out Zentyal as a prospective alternative to Windows AD for our organization. However, some of the softwares used by our instruments are unable to connect to the Zentyal AD. They are mainly Agilent OpenLab softwares. They connect very easily with Windows server AD (have tested with server 2008). However, none of the OpenLab softwares connect to the Zentyal AD. Is there any fundamental difference between the way samba handles AD connections and the way that windows server handles it? I am attaching some of the software logs that were generated and frequently referred to by the Agilent team.

PS: I am new into active directory implementation and hence it would be very helpful if some of the experts in Zentyal can guide me to get this software working.

Software log when trying to connect to Zentyal:

[activitylog][2020-11-27T16:35:54.234+05:30][Info][17fc:19]:Last indexed log entry: 549
[lucene][2020-11-27T16:35:54.308+05:30][Info][17fc:19]:Lucene committed
[activitylog][2020-11-27T16:35:54.330+05:30][Info][17fc:19]:Last indexed log entry: 550
[activitylog][2020-11-27T16:35:54.434+05:30][Info][17fc:19]:Last indexed log entry: 550
[lucene][2020-11-27T16:35:54.519+05:30][Info][17fc:19]:Lucene committed
[activitylog][2020-11-27T16:35:54.547+05:30][Info][17fc:19]:Last indexed log entry: 551
[][2020-11-27T16:38:41.453+05:30][Warning][17fc:33]:Expected exception: Agilent.OpenLab.SharedServices.Exceptions.ProviderNotAvailableException: The server is unavailable. ---> System.DirectoryServices.Protocols.LdapException: The server is unavailable. ---> System.DirectoryServices.Protocols.DirectoryOperationException: The server is unavailable.
   at System.DirectoryServices.Protocols.LdapConnection.ConstructResponse(Int32 messageId, LdapOperation operation, ResultAll resultType, TimeSpan requestTimeOut, Boolean exceptionOnTimeOut)
   at System.DirectoryServices.Protocols.LdapConnection.SendRequest(DirectoryRequest request, TimeSpan requestTimeout)
   at System.DirectoryServices.Protocols.LdapConnection.SendRequest(DirectoryRequest request)
   at Agilent.OpenLab.Security.WindowsMembershipManager.Ldap.LdapExtensions.FindOne(LdapConnection connection, String distinguishedName, String filter, SearchScope scope, String[] attributes)
   --- End of inner exception stack trace ---
   at Agilent.OpenLab.Security.WindowsMembershipManager.Ldap.LdapExtensions.FindOne(LdapConnection connection, String distinguishedName, String filter, SearchScope scope, String[] attributes)
   at Agilent.OpenLab.Security.WindowsMembershipManager.LdapMembershipManager`1.ReadServerInfo()
   --- End of inner exception stack trace ---
   at Agilent.OpenLab.Security.WindowsMembershipManager.LdapMembershipManager`1.ReadServerInfo()
   at Agilent.OpenLab.Caching.CacheExtension.TryGet[TKey,TValue](ICache`2 cache, TKey key, Func`1 realAction)
   at Agilent.OpenLab.Security.WindowsMembershipManager.LdapMembershipManager`1..ctor(WinMembershipManagerConfig config, Boolean resetServerInfoCache)
   at Agilent.OpenLab.Administration.Service.AuthenticationAndStorageManager.GetWinDomains(WindowsDomainParams authParams)
   at Agilent.OpenLab.Administration.Service.AuthenticationAndStorageManager.CheckWinDomainParameters(WindowsDomainParams authParams)

Please let me know any additional information that might be needed.
« Last Edit: November 28, 2020, 07:52:34 am by chinmaycomp »

badapple7

  • Zen Apprentice
  • *
  • Posts: 26
  • Karma: +10/-0
    • View Profile
Re: Unable to get a lab software to Zentyal domain
« Reply #1 on: November 27, 2020, 11:59:19 pm »
hi! could be problem on version of protocol smb, WIn2008 run smb2.1, but samba(4.7.6) on zentyal is run smb3.11, if I remember correctly. What version smb run Agilent OpenLab softwares?

chinmaycomp

  • Zen Apprentice
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: Unable to get a lab software to Zentyal domain
« Reply #2 on: November 28, 2020, 07:44:32 am »
hi! could be problem on version of protocol smb, WIn2008 run smb2.1, but samba(4.7.6) on zentyal is run smb3.11, if I remember correctly. What version smb run Agilent OpenLab softwares?

Hi! Thanks for replying. Actually, their software does run on server 2019 as well. Server 2019 uses smb 3.11 right? According to what their team told me, their software uses the netapi32.dll to communicate with the domain controller. Is that of any help? Their software mentions an error about incorrect credentials, but in reality, it is unable to find the server when I check it in the logs. I am unable to attach a screenshot here, so here's the link --> https://imgur.com/a/zvSDnUH

Expected exception: Agilent.OpenLab.SharedServices.Exceptions.ProviderNotAvailableException: The server is unavailable. ---> System.DirectoryServices.Protocols.LdapException: The server is unavailable. ---> System.DirectoryServices.Protocols.DirectoryOperationException: The server is unavailable.

I used server 2008 in test lab just because it was available with me and samba's functional level could be raised to 2008 as well.
« Last Edit: November 28, 2020, 07:56:29 am by chinmaycomp »