Author Topic: Zentyal 6.1 painfully slow  (Read 566 times)

devnull

  • Zen Apprentice
  • *
  • Posts: 17
  • Karma: +12/-0
    • View Profile
Zentyal 6.1 painfully slow
« on: September 11, 2020, 02:35:14 pm »
Hi,
I have a problem with Zentyal 6.1. For several days it started to run very slow. I need to wait minutes to change menu section in the admin interface. Even execute of the
Code: [Select]
sudo /etc/init.d/zentyal modulename restart lasts 2-3 minutes.

/var/log/zentyal/error.log
Code: [Select]
/var/log/zentyal/error.log:446:2020/09/11 13:52:03 [error] 5014#5014: *10434 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 192.168.7.1, server: , request: "GET /Dashboard/WidgetJSON?module=sysinfo&widget=modules HTTP/1.1", upstream: "uwsgi://unix:///run/zentyal-webadmin/webadmin.sock", host: "192.168.7.2:8443", referrer: "https://192.168.7.2:8443/Dashboard/Index"

Other services on the server seem to run normally. iotop and htop show no sign of the problem.

doncamilo

  • Zen Samurai
  • ****
  • Posts: 478
  • Karma: +165/-1
    • View Profile
Re: Zentyal 6.1 painfully slow
« Reply #1 on: September 18, 2020, 05:21:44 pm »
 :)

A trick:

{code:bash}
sudo zs modulename restart
{code}

Did you check /var/log/zentyal/zentyal.log, /var/log/zentyal/uwsgi.log and /var/log/nginx/error.log?

The first one will give you keys of the error, the others will give you more detailed info if webadmin is the problem.

In this case I recommend you:

Code: [Select]
sudo zs webadmin restart
And if this fails:

Code: [Select]
sudo systemctl status zentyal.webadmin-uwsgi.service
sudo systemctl status zentyal.webadmin-nginx.service
#Start or restart if needed
sudo systemctl restart zentyal.webadmin-uwsgi.service
#... etc.

Though I think that the issue is probably related with the workload of your server. Install nmon and monitorize your system some days.

Cheers!

« Last Edit: September 18, 2020, 05:23:32 pm by doncamilo »
- Do my pigeons bother you passing over your land?
- They block the sun!

G. Guareschi., Don Camillo.,

devnull

  • Zen Apprentice
  • *
  • Posts: 17
  • Karma: +12/-0
    • View Profile
Re: Zentyal 6.1 painfully slow
« Reply #2 on: September 24, 2020, 08:07:22 pm »
Thanks for the suggestion. Using Zabbix I was able to find out what was wrong. System was running out of memory becouse of hundreds of samba processes being spawned. Propably a samba's memory leak. Fortunately the problem is gone in 6.2.