Author Topic: [SOLVED] Zentyal Mail Filter not Starting  (Read 652 times)

johan.badenhorst

  • Zen Apprentice
  • *
  • Posts: 9
  • Karma: +3/-0
    • View Profile
[SOLVED] Zentyal Mail Filter not Starting
« on: June 03, 2020, 11:54:29 am »
Dear All,

Since my upgrade from 6.1 to 6.2 and using the workaround to install zentyal-antivirus and zentyal-mailfilter in this post - https://forum.zentyal.org/index.php/topic,34976.0.html

I cannot start the MailFilter module. when enabling it simply remains "Stopped", if I restart the module, I am greeted with "The module has started successfully." However the Module Status remains stopped.

I have gone through all the logs that I can find but cannot find a reason why this is happening... anyone that can point me in the right direction?
« Last Edit: June 04, 2020, 03:57:42 pm by johan.badenhorst »

johan.badenhorst

  • Zen Apprentice
  • *
  • Posts: 9
  • Karma: +3/-0
    • View Profile
Re: Zentyal Mail Filter not Starting
« Reply #1 on: June 04, 2020, 12:33:44 pm »
So after no pointers in the right direction I started breaking down the init.d for amavis and noticed that if the Binaries are not found that the init.d simply exit with error code 0.

I traced the binaries and saw that the although Ubuntu reported amavisd-new as installed the binaries were missing. I did an apt --reinstall amavisd-new which re-installed 1:2.11.0-1ubuntu1.1 and low and behold the mailfilter module started, after a manual service amavis restart that is..

Next another snag hit, when attempting to do a manual sa-learn for SpamAssassin, I was greated with failure. running the same sa-learn command with the -D option showed me that the amavis user did not have access to the spamassassin db in mysql

This was fixed using the following

GRANT ALL PRIVILEGES ON spamassassin.* TO 'amavis'@'localhost' IDENTIFIED BY '*******';

The password obscured by the asterisks was obtained from /etc/spamassassin/local.cf at the "bayes_sql_password" line.

Hope this helps someone else with this issue



 

doncamilo

  • Zen Samurai
  • ****
  • Posts: 478
  • Karma: +165/-1
    • View Profile
Re: [SOLVED] Zentyal Mail Filter not Starting
« Reply #2 on: June 08, 2020, 12:45:52 pm »
 :)

The bug has been fixed with the last zentyal-antivirus package.

Cheers!
- Do my pigeons bother you passing over your land?
- They block the sun!

G. Guareschi., Don Camillo.,