Author Topic: email alert?  (Read 376 times)

killmasta93

  • Zen Apprentice
  • *
  • Posts: 31
  • Karma: +6/-0
    • View Profile
email alert?
« on: February 27, 2020, 03:15:10 am »
Hi,
I was wondering if someone else is having this issue before? currently running 6.1 and constantly getting email alert with this
Code: [Select]
/etc/cron.hourly/90zentyal-manage-logs:
/etc/cron.hourly/90zentyal-manage-logs: line 3: /usr/share/zentyal/manage-logs: No such file or directory
run-parts: /etc/cron.hourly/90zentyal-manage-logs exited with return code 127

Thank you

killmasta93

  • Zen Apprentice
  • *
  • Posts: 31
  • Karma: +6/-0
    • View Profile
Re: email alert?
« Reply #1 on: March 01, 2020, 04:41:30 am »
bump?

doncamilo

  • Zen Samurai
  • ****
  • Posts: 377
  • Karma: +99/-1
    • View Profile
Re: email alert?
« Reply #2 on: March 09, 2020, 11:48:41 am »
 :)

You lost one of the Perl scripts which checks the logs managing system. Do you have broken packages?

Code: [Select]
dpkg -l | grep -Ev '^(ii|rc)'

https://raw.githubusercontent.com/zentyal/zentyal/master/main/core/src/scripts/manage-logs

Cheers!
"Tanta salud goces como bondad abrigues en tu corazón"

Don Camilo.

"That place... is strong with the
dark side of the Force.  A domain
of evil it is.  In you must go."

Yoda.

killmasta93

  • Zen Apprentice
  • *
  • Posts: 31
  • Karma: +6/-0
    • View Profile
Re: email alert?
« Reply #3 on: March 12, 2020, 04:29:40 am »
Thanks for the reply, so i what i did i had another zentyal installation working copy the script but i rebooted now i cannot access the webGUI i get the 404 error NGINX not found :(

Code: [Select]
root@zentyal:~# dpkg -l | grep -Ev '^(ii|rc)'
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                                  Version                                         Architecture Description
+++-=====================================-===============================================-============-===============================================================================

then i tried running it manually the script i got this error

Code: [Select]
root@zentyal:/etc/cron.hourly# ./90zentyal-manage-logs
Can't locate EBox.pm in @INC (you may need to install the EBox module) (@INC contains: /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.26.1 /usr/local/share/perl/5.26.1 /usr/lib/x86_64-linux-gnu/perl5/5.26 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.26 /usr/share/perl/5.26 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base) at /usr/share/zentyal/manage-logs line 6.
BEGIN failed--compilation aborted at /usr/share/zentyal/manage-logs line 6.
« Last Edit: March 12, 2020, 04:31:28 am by killmasta93 »

doncamilo

  • Zen Samurai
  • ****
  • Posts: 377
  • Karma: +99/-1
    • View Profile
Re: email alert?
« Reply #4 on: April 11, 2020, 05:05:29 pm »
 :)

This is interesting! Your perl @INC environment variable is correct (here you can see the @INC from one of my test systems):

Code: [Select]
zenadmin@khazad-dum:~$ perl -le 'print for @INC'
/etc/perl
/usr/local/lib/x86_64-linux-gnu/perl/5.26.1
/usr/local/share/perl/5.26.1
/usr/lib/x86_64-linux-gnu/perl5/5.26
[b]/usr/share/perl5[/b]
/usr/lib/x86_64-linux-gnu/perl/5.26
/usr/share/perl/5.26
/usr/local/lib/site_perl
/usr/lib/x86_64-linux-gnu/perl-base

The EBox API is deployed in '/usr/share/perl5/EBox'. So the EBox packages are actually included into your @INC array.

My 90zentyal-manage-logs file:

Code: [Select]
root@khazad-dum:~# cat /etc/cron.hourly/90zentyal-manage-logs
#!/bin/bash

/usr/share/zentyal/manage-logs

But , on the contrary than you, if I run the script manually, I haven't any error:

Code: [Select]
root@khazad-dum:~# bash -x /etc/cron.hourly/90zentyal-manage-logs
+ /usr/share/zentyal/manage-logs
root@khazad-dum:~#

So, your issue deserves some more attention. Could you send here som more info about this issue? Did you install some other perl version in addition to the official one? Did you install your 6.1 from scratch or is this an old zentyal version upgraded to 6.1?

Cheers!



"Tanta salud goces como bondad abrigues en tu corazón"

Don Camilo.

"That place... is strong with the
dark side of the Force.  A domain
of evil it is.  In you must go."

Yoda.

killmasta93

  • Zen Apprentice
  • *
  • Posts: 31
  • Karma: +6/-0
    • View Profile
Re: email alert?
« Reply #5 on: April 11, 2020, 07:02:16 pm »
Thanks for the reply, what i fix the issue was updating the zentyal to 6.1 it was on 6.0 very odd first time i got this error i have around 6 zentyal installations working fine