Author Topic: file shared error please help  (Read 555 times)

tekvizyon

  • Zen Apprentice
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
file shared error please help
« on: February 10, 2020, 11:56:48 am »
Hi

I want to share files, but for the folder to be shared

When I check folder privileges with getfacl, 134 is added before my user name.

user: ahmet

getfacl

user: domain \ 134ahmet

I installed the system on different machines 3 times, but the result did not change.

I cannot access the folders that share the domain, you are not authorized.

tekvizyon

  • Zen Apprentice
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: file shared error please help
« Reply #1 on: February 11, 2020, 08:50:23 am »
please help me

basselope

  • Zen Monk
  • **
  • Posts: 63
  • Karma: +17/-0
    • View Profile
Re: file shared error please help
« Reply #2 on: February 11, 2020, 10:49:34 am »
Have you started by setting up a basic share on Zentyal under File Sharing menu and giving it reasonable permissions, say "Read and Write" for "Domain Users"?
Can you access that basic share?


doncamilo

  • Zen Samurai
  • ****
  • Posts: 478
  • Karma: +165/-1
    • View Profile
Re: file shared error please help
« Reply #3 on: February 12, 2020, 02:39:13 pm »
 :)

These values are correct (see here my own values for the share "eriador"):

Code: [Select]
root@pusa:~# ls -l /home/samba/shares/
total 8
drwxrwx---+ 2 TIERRAMEDIA\administrator adm 4096 feb 11 17:42 eriador
root@pusa:~# ls -l /home/samba/shares/
total 8
drwxrwx---+ 2 TIERRAMEDIA\administrator adm 4096 feb 11 17:42 eriador
root@pusa:~# getfacl /home/samba/shares/eriador
getfacl: Removing leading '/' from absolute path names
# file: home/samba/shares/eriador
# owner: TIERRAMEDIA\134administrator
# group: adm
user::rwx
user:TIERRAMEDIA\134administrator:rwx
user:TIERRAMEDIA\134gimli:rwx
user:TIERRAMEDIA\134elrohir:rwx
user:TIERRAMEDIA\134elladan:rwx
group::rwx
group:adm:rwx
group:TIERRAMEDIA\134domain\040admins:rwx
mask::rwx
other::---
default:user::rwx
default:user:TIERRAMEDIA\134administrator:rwx
default:user:TIERRAMEDIA\134gimli:rwx
default:user:TIERRAMEDIA\134elrohir:rwx
default:user:TIERRAMEDIA\134elladan:rwx
default:group::rwx
default:group:adm:rwx
default:group:TIERRAMEDIA\134domain\040admins:rwx
default:mask::rwx
default:other::---

You can see the configuration that has effectively your share this way:

Code: [Select]
root@pusa:~# cat /etc/samba/shares.conf
[homes]
    comment = Home Directories
    path = /home/%S
    read only = no
    browseable = no
    create mask = 0611
    directory mask = 0711
    vfs objects = acl_xattr
    full_audit:success = connect opendir disconnect unlink mkdir rmdir open rename
    full_audit:failure = connect opendir disconnect unlink mkdir rmdir open rename

# Shares

[eriador]
    path = /home/samba/shares/eriador
    browseable = yes
    force create mode = 0660
    force directory mode = 0660
    valid users = "gimli", "elladan", "elrohir", "gimli"
    read list =
    write list = "gimli", "elladan", "elrohir"
    admin users = "gimli"
    vfs objects = acl_xattr
    full_audit:failure = connect opendir disconnect unlink mkdir rmdir open rename

You have to use the acl's system of the Zentyal webadmin to grant access to the users or groups you need:



The options you chose in the previous screenshot manages the shares.conf file I showed you before. Try to grant access to the share to some user or group instead of the global domain users group.

Tell us if this fixes your problem.

Cheers!
- Do my pigeons bother you passing over your land?
- They block the sun!

G. Guareschi., Don Camillo.,