Author Topic: Problemas con el dasboard  (Read 157 times)

havacuban

  • Zen Apprentice
  • *
  • Posts: 42
  • Karma: +1/-0
    • View Profile
Problemas con el dasboard
« on: December 18, 2019, 05:17:12 pm »
hola comunidad

Tengo un problema después de actulizar el zentyal-core 6.1.2 no puedo abrir mi dasboard , me da el siguiente error 504 gateway time-out
revisando he modificado algunos parámetros en nginx pero sin resultados .
alguien me pude dar alguna pista para buscar ?

saludos

doncamilo

  • Zen Samurai
  • ****
  • Posts: 336
  • Karma: +69/-1
    • View Profile
Re: Problemas con el dasboard
« Reply #1 on: December 19, 2019, 12:20:45 pm »
 :)

Comprueba si se instaló correctamente el paquete (y si tienes paquetes rotos)

Code: [Select]
dpkg -l | grep -Ev '^(ii|rc)'
# o apt-get check

¿Cómo accedes a tu webadmin? ¿Mediante una url formada por el nombre de dominio o mediante la IP? ¿Estás accediendo desde la red local o a través de la Internet? ¿Tienes habilitado algún proxy?

Mira los logs:

Code: [Select]
less /var/log/zentyal/uwsgi.log
less /var/log/zentyal/error.log

¿Tu DNS server está funcionando correctamente? ¿Tienes conectividad con la interfaz de red por la que accedes a webadmin?

Code: [Select]
sudo zs network status

¿Tu dns está correctamente configurado?

Code: [Select]
# en el server
sudo host -al domain.tld

Salud y Feliz Navidad!





"That place... is strong with the
dark side of the Force.  A domain
of evil it is.  In you must go."

Yoda.

havacuban

  • Zen Apprentice
  • *
  • Posts: 42
  • Karma: +1/-0
    • View Profile
Re: Problemas con el dasboard
« Reply #2 on: December 19, 2019, 06:15:15 pm »
gracias por la pronta respuesta
bueno esto es lo que tengo
1.  apt-get check
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho

2.*** Starting uWSGI 2.0.15-debian (64bit) on [Tue Dec 17 10:43:06 2019] ***
compiled with version: 7.3.0 on 28 September 2018 15:41:15
os: Linux-4.15.0-72-generic #81-Ubuntu SMP Tue Nov 26 12:20:02 UTC 2019
nodename: correozentyal
machine: x86_64
clock source: unix
pcre jit disabled
detected number of CPU cores: 8
current working directory: /
detected binary path: /usr/bin/uwsgi-core
dropping root privileges as early as possible
setgid() to 116
set additional group 4 (adm)
set additional group 42 (shadow)
setuid() to 110
your processes number limit is 31343
your memory page size is 4096 bytes
detected max file descriptor number: 1024
lock engine: pthread robust mutexes
thunder lock: disabled (you can enable it with --thunder-lock)
uwsgi socket 0 bound to UNIX address /run/zentyal-webadmin/webadmin.sock fd 3
dropping root privileges after socket binding
initialized Perl 5.26.1 main interpreter at 0x5578bb5d2eb0
dropping root privileges after plugin initialization
your server socket listen backlog is limited to 100 connections
your mercy for graceful operations on workers is 60 seconds
mapped 157824 bytes (154 KB) for 1 cores
*** Operational MODE: single process ***
PSGI app 0 (/usr/share/zentyal/psgi/zentyal.psgi) loaded in 0 seconds at 0x5578bfbc7340 (interpreter 0x5578bb5d2eb0)
dropping root privileges after application loading
*** uWSGI is running in multiple interpreter mode ***
spawned uWSGI master process (pid: 9627)
spawned uWSGI worker 1 (pid: 9629, cores: 1)
Tue Dec 17 10:53:30 2019 - uwsgi_response_writev_headers_and_body_do(): Broken pipe [core/writer.c line 296] during GET / (127.0.0.1)
[pid: 9629|app: 0|req: 1/1] 127.0.0.1 () {46 vars in 710 bytes} [Tue Dec 17 10:43:06 2019] GET / => generated 0 bytes in 623722 msecs (HTTP/1.1 200) 2:

3.2019/10/14 09:46:33 [error] 4053#4053: *693291 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 127.0.0.1, server: , request: "GET /SysInfo/RestartService?module=mail&restart=Reiniciar HTTP/1.1", upstream: "uwsgi://unix:///run/zentyal-webadmin/webadmin.sock", host: "localhost:8443", referrer: "https://localhost:8443/"
2019/10/14 09:46:53 [error] 4053#4053: *693232 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 127.0.0.1, server: , request: "GET /Dashboard/WidgetJSON?module=sysinfo&widget=general HTTP/1.1", upstream: "uwsgi://unix:///run/zentyal-webadmin/webadmin.sock", host: "localhost:8443", referrer: "https://localhost:8443/Dashboard/Index"
2019/10/14 09:46:53 [error] 4053#4053: *693474 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 127.0.0.1, server: , request: "GET /Dashboard/WidgetJSON?module=sysinfo&widget=modules HTTP/1.1", upstream: "uwsgi://unix:///run/zentyal-webadmin/webadmin.sock", host: "localhost:8443", referrer: "https://localhost:8443/Dashboard/Index"
2019/10/14 09:46:53 [error] 4053#4053: *693493 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 127.0.0.1, server: , request: "GET /Dashboard/WidgetJSON?module=sysinfo&widget=links HTTP/1.1", upstream: "uwsgi://unix:///run/zentyal-webadmin/webadmin.sock", host: "localhost:8443", referrer: "https://localhost:8443/Dashboard/Index"
2019/10/14 09:46:53 [error] 4053#4053: *693483 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 127.0.0.1, server: , request: "GET /Dashboard/WidgetJSON?module=network&widget=interfaces HTTP/1.1", upstream: "uwsgi://unix:///run/zentyal-webadmin/webadmin.sock", host: "localhost:8443", referrer: "https://localhost:8443/Dashboard/Index"
2019/10/14 09:46:53 [error] 4053#4053: *693669 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 127.0.0.1, server: , request: "GET /Dashboard/WidgetJSON?module=dhcp&widget=dhcpleases HTTP/1.1", upstream: "uwsgi://unix:///run/zentyal-webadmin/webadmin.sock", host: "localhost:8443", referrer: "https://localhost:8443/Dashboard/Index"
2019/10/14 10:03:17 [error] 4053#4053: *693669 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 127.0.0.1, server: , request: "GET /SysInfo/RestartService?module=mailfilter&restart=Reiniciar HTTP/1.1", upstream: "uwsgi://unix:///run/zentyal-webadmin/webadmin.sock", host: "localhost:8443", referrer: "https://localhost:8443/Dashboard/Index"
2019/11/25 14:42:53 [error] 4031#4031: *684 upstream prematurely closed connection while reading response header from upstream, client: 127.0.0.1, server: , request: "POST /SysInfo/Controller/Halt HTTP/1.1", upstream: "uwsgi://unix:///run/zentyal-webadmin/webadmin.sock:", host: "localhost:8443", referrer: "https://localhost:8443/SysInfo/View/Halt"

4.Zentyal: status module network:         [ RUNNING ]


esto son las salidas de los log
saludos y gracias