Author Topic: Domain Controller and samba access logs problem  (Read 299 times)

prx

  • Zen Apprentice
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Domain Controller and samba access logs problem
« on: November 19, 2019, 06:52:01 pm »
Hi,

first of all I'm sorry for my poor English...

I installed Zentyal Development Edition 6.1 and configured it as stand alone domain controller. Then I created a group: Test and then I created 2 users: user1 (belonging to the group Domain Admins) and user2 (belonging to the group Test). Then I joined a Windows 10 VM to the Domain controller and all it is ok, the 2 users created (user1 and user2) can authenticate successfully to the domain controller but the problem is whit samba access control. When user1 do authentication I have only one row in the access log whit action connect, but if user2 do authentication in the access log I have two rows, one with action connect and one with action disconnect. User2 can work normally, the windows 10 VM is not disconnected as log access says.
In /var/log/syslog for user1 I have:
    Nov 19 18:04:37 zentyal smbd_audit: ZENTYAL-DOMAIN\user1|192.168.155.104|connect|ok|user1
while for user2:
    Nov 19 18:47:08 zentyal smbd_audit: ZENTYAL-DOMAIN\user2|192.168.155.104|connect|ok|user2
    Nov 19 18:47:09 zentyal smbd_audit: ZENTYAL-DOMAIN\user2|192.168.155.104|disconnect|ok|user2

But the user 2, of course is not disconnected and works perfectly.

The question is: why for the user2 I have also the second row with action disconnect?

Thank you very much