Author Topic: Brocken Packages al ACTUALIZAR Zentyal!!!  (Read 141 times)

MitNicK

  • Zen Apprentice
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Brocken Packages al ACTUALIZAR Zentyal!!!
« on: November 08, 2019, 12:28:18 am »
Trato de actualizar mi zentyal 4.2 dev ... a 5.1 y cuando le ejecuto el comando para q actualice al final me da este error...

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 zentyal-software : Depends: zentyal-core (>= 5.1) but 4.2 is to be installed
E: Unable to correct problems, you have held broken packages.


doncamilo

  • Zen Samurai
  • ****
  • Posts: 331
  • Karma: +68/-1
    • View Profile
Re: Brocken Packages al ACTUALIZAR Zentyal!!!
« Reply #1 on: November 11, 2019, 05:21:06 pm »
 :)

Pega aquí el contenido de tu /etc/apt/sources.list (y de cualquier archivo contenido en /etc/apt/sources.list.d). Después ejecuta los comandos
Code: [Select]
sudo sudo apt-get check o
Code: [Select]
sudo dpkg -l | grep -Ev '^(ii|rc)' y
Code: [Select]
sudo dpkg -l zentyal-* y pega aquí los resultados a ver qué se puede hacer.

Me temo que había algo mal en tu repositorio APT y has entrado en el https://en.wikipedia.org/wiki/Dependency_hell

¡Salud!

"That place... is strong with the
dark side of the Force.  A domain
of evil it is.  In you must go."

Yoda.