Author Topic: Replication Failing due to Schema Mismatch  (Read 393 times)

jtoninger

  • Zen Apprentice
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Replication Failing due to Schema Mismatch
« on: October 03, 2019, 08:50:38 pm »
Hi All,

I had a prior replication issue I was unable to resolve: https://forum.zentyal.org/index.php/topic,33655.0.html

I ended up demoting that instance of Zentyal and installing a fresh version. Things worked well for a few weeks but now I have encountered a new issue.

I joined a server in a Branch Office to AD, and it looks like the Zentyal server handled the request. If I connect to that DC and check, I see the computer object. But it does not seem to be replicating to other DC's.

Event viewer now complains about a schema mismatch.

Quote
Replication of application directory partition DC=gardien,DC=com from source 40502013-4ca6-435c-b40b-cf265a649a10 (zenserver.domain.com) has been aborted. Replication requires consistent schema but last attempt to synchronize the schema had failed. It is crucial that schema replication functions properly. See previous errors for more diagnostics. If this issue persists, please contact Microsoft Product Support Services for assistance. Error 8418: The replication operation failed because of a schema mismatch between the servers involved..

If I force replication from Windows servers to Windows servers all is fine. If I force replication from a Windows Server To the Zen server all is fine. If I try to replicate FROM the Zen server I get the issue above.

I'm not having much luck tracking this one down. Any help appreciated.

Thanks!


----Update

I tried running
Code: [Select]
samba-tool drs replicate --full-sync to force the Zentayal DC to start a fresh replication but the issue persists.
« Last Edit: October 07, 2019, 04:25:29 pm by jtoninger »