Author Topic: Issue installing apt-add-repository after Zentyal 5 install on Ubuntu 16.04  (Read 2909 times)

arcnet

  • Zen Apprentice
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
I started with a clean install of Ubuntu 16.04 and added the zentyal repo:

/etc/apt/sources.list:
----
# Zentyal Repo
deb http://archive.zentyal.org/zentyal 5.0 main

----

I installed zentayl using:
# apt-get install zentyal-core

Then configured and added packages via Zentyal web interface.

After installing zentyal I wanted to install letsencrypt cerbot however when I try to install required packages apt wants to remove important zentyal and system packages and I'm not understanding the reason.

# add-apt-repository ppa:certbot/certbot
The program 'add-apt-repository' is currently not installed. You can install it by typing:
apt install software-properties-common

# apt install software-properties-common
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  amavisd-new apache2 apache2-data apache2-utils archivemail arj
  ...
  python-dnspython python-gdbm python-ldb python-samba python-talloc
  python-tdb pyzor razor samba samba-common samba-common-bin samba-libs
  samba-vfs-modules sogo sogo-activesync sope4.9-gdl1-mysql
  sope4.9-gdl1-postgresql sope4.9-libxmlsaxdriver spamassassin spamc tdb-tools
  tmpreaper unrar-free update-inetd wakeonlan winbind zentyal-antivirus
  zentyal-dns zentyal-firewall zentyal-network zentyal-ntp
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
  apt apt-utils gnupg gnupg-agent libgpgme11 pinentry-curses
  samba-dsdb-modules snap-confine snapd tasksel tasksel-data
  ubuntu-core-launcher ubuntu-minimal unattended-upgrades zentyal-groupware
  zentyal-mail zentyal-mailfilter zentyal-samba zentyal-sogo
The following NEW packages will be installed:
  software-properties-common
WARNING: The following essential packages will be removed
This should NOT be done unless you know exactly what you are doing!
  apt gnupg (due to apt)
0 to upgrade, 1 to newly install, 19 to remove and 3 not to upgrade.
Need to get 0 B/9,452 B of archives.
After this operation, 68.7 MB disk space will be freed.
You are about to do something potentially harmful.
To continue type in the phrase 'Yes, do as I say!'
 ?]


I had a similar message trying to install python-software-properties. Can anyone tell me why this is trying to remove apt and zentyal packages and how I can install add-apt-repository without potentially hosing the system?

Thanks.

dadaniel

  • Zen Apprentice
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
I have the same problem with the Zentyal community release iso installation. Any ideas?

sangamc

  • Zen Monk
  • **
  • Posts: 54
  • Karma: +2/-0
    • View Profile
https://forum.zentyal.org/index.php?topic=30815.0

I see someone found a way around this issue but it involves a few hoops that need jumping through. Very dissapointed with this problem. It is holding me back from deplying Zentyal 5 at all my customer locations

Neustradamus

  • Zen Monk
  • **
  • Posts: 92
  • Karma: +0/-5
    • View Profile
I have created a ticket for Let's Encrypt support:
-> https://github.com/zentyal/zentyal/issues/1836

Can you help?

Neustradamus

  • Zen Monk
  • **
  • Posts: 92
  • Karma: +0/-5
    • View Profile
Since my first ticket for Let's Encrypt support: https://github.com/zentyal/zentyal/issues/1836 (it has been closed by Zentyal Team).

I have created a second ticket for Let's Encrypt support which has been closed by Zentyal Team too.

I have created a third ticket for Let's Encrypt support, can you like, comment on it?
- https://github.com/zentyal/zentyal/issues/2015