Author Topic: some problem with sogo  (Read 505 times)

futuraservice

  • Zen Apprentice
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
some problem with sogo
« on: August 01, 2019, 04:07:12 pm »
Hellooooo  ;D ;D ;D ;D ;D ;D :D :D :D :D

I find these issues with sogo:
I resolved the problem of shared MailBox (https://forum.zentyal.org/index.php/topic,33589.0.html).

1) If I delete some emails inside Trash folder of shared mailbox with my personal account, they are moved in my personal Trash folder. Why???I expect their final cancellation.

2) With my personal account, when I click on email of shared Mailbox, it marks as "read". Is it possible to not mark the email? I will want to mark as "read" by myself clicking  "Mark as Unread" on the options

doncamilo

  • Zen Warrior
  • ***
  • Posts: 130
  • Karma: +22/-0
    • View Profile
Re: some problem with sogo
« Reply #1 on: August 01, 2019, 05:20:17 pm »
 ;)

When you "remove" a message it isn't actually erased from the system, simply, it's marked with the flag "/deleted" or moved to a trash folder.

IMAP4 clients simply doesn't shows the mails flagged as "/deleted".

E-mail client has to trigger the order "expunge" in order to remove the e-mail effectively. So the behaviour you described is normal.

As a sysadmin, of course, you have some "tricks" in order to do these kind of stuff that rest of people can't  ::) :
https://wiki.dovecot.org/Tools/Doveadm/Expunge

In relation with point 2, I don't know if there's some config option on your e-mail client but you can play with the imap4 flags  manually:

https://wiki.dovecot.org/Tools/Doveadm/Flags

Cheers!