Author Topic: LDAP Problem after last update  (Read 2312 times)

Rosco

  • Zen Apprentice
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
LDAP Problem after last update
« on: April 01, 2010, 03:15:03 pm »
Hi to all,
after an update i can't access to users page and proxy autentication do not work. When te server starts LDAP go on error, in the logs i find that LDAP could not connect to 127.0.0.1:389, can someone help me??


J. A. Calvo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1986
  • Karma: +67/-3
    • View Profile
    • http://blogs.zentyal.org/jacalvo
Re: LDAP Problem after last update
« Reply #1 on: April 01, 2010, 03:21:45 pm »
If you execute "/etc/init.d/slapd" stop and then execute "slapd -d 256", do you see any error?
Zentyal Server Lead Developer

Rosco

  • Zen Apprentice
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: LDAP Problem after last update
« Reply #2 on: April 01, 2010, 06:50:19 pm »
root@proxy:~# slapd -d 256
@(#) $OpenLDAP: slapd 2.4.21 (Jan 19 2010 14:30:07) $
        buildd@iridium:/build/buildd/openldap-2.4.21/debian/build/servers/slapd
config error processing cn={2}asterisk,cn=schema,cn=config: olcAttributeTypes: Duplicate attributeType: ""
slapd stopped.
connections_destroy: nothing to destroy.

J. A. Calvo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1986
  • Karma: +67/-3
    • View Profile
    • http://blogs.zentyal.org/jacalvo
Re: LDAP Problem after last update
« Reply #3 on: April 01, 2010, 07:14:11 pm »
Could you show us the contents of this file?

/etc/ldap/slap.d/cn=config/cn=schema/cn={2}asterisk.ldif
Zentyal Server Lead Developer

Rosco

  • Zen Apprentice
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: LDAP Problem after last update
« Reply #4 on: April 01, 2010, 08:08:57 pm »
there is not that file!

MMaI

  • Zen Apprentice
  • *
  • Posts: 11
  • Karma: +0/-0
    • View Profile
Re: LDAP Problem after last update
« Reply #5 on: April 05, 2010, 12:56:17 am »
refer to http://forum.ebox-platform.com/index.php?topic=3396.msg14753#msg14753
same issue, see if the file I mentioned there exists and rename it to {2}asterisk.ldif or delete it if theres already a file named {x}asterisk.ldif where x is an integer

Rosco

  • Zen Apprentice
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: LDAP Problem after last update
« Reply #6 on: April 08, 2010, 08:12:54 am »
Thank you very much!!!
Rosco

sixstone

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1417
  • Karma: +26/-0
    • View Profile
    • Sixstone's blog
Re: LDAP Problem after last update
« Reply #7 on: April 08, 2010, 02:58:08 pm »
Hi to all,
after an update i can't access to users page and proxy autentication do not work. When te server starts LDAP go on error, in the logs i find that LDAP could not connect to 127.0.0.1:389, can someone help me??

Could you tell me which version are coming from in the update?

Best regards,
My secret is my silence...