Author Topic: Open VPN wont connect after about 4 weeks  (Read 1898 times)

Milbs1979

  • Zen Apprentice
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Open VPN wont connect after about 4 weeks
« on: May 29, 2019, 10:44:38 am »
Hi All,

I have an issue on my Zentyal Development Edition Server. Open VPN drops all user authentication after about 4 weeks. OpenVPN does not complete the TLS Handshake. If I regenerate the certificates and reinstall the client then the connectivity is restored. I have checked the certificates are valid and have recreated them to be certain.

As the users can reconnect with a reinstall I believe the networking to be set up correctly. I suspect there is parameter that is set somewhere to disable the access after a certain time. When the service stops it is for all users at the same time. This could be a coincidence though as they are set up at the same time (4 users total).

I would appreciate some guidance - Thank you

vshaulsk

  • Zen Samurai
  • ****
  • Posts: 475
  • Karma: +9/-1
    • View Profile
Re: Open VPN wont connect after about 4 weeks
« Reply #1 on: May 29, 2019, 10:41:47 pm »
I have the same issue ....... it is frustrating enough that I am thinking of moving away from Zentyal

royceb

  • Guest
Re: Open VPN wont connect after about 4 weeks
« Reply #2 on: May 30, 2019, 01:28:40 am »
It's a problem with the default config that got shipped with Zentyal

https://community.spiceworks.com/how_to/158901-how-to-fix-openvpn-zentyal-verify-error-depth-0-error-crl-has-expired-on-ubuntu

Do steps 1 - 2; then in the web interface you have to re-sign all of the existing certificates and redeploy your VPN credentials to your client machines.
Modify message

Milbs1979

  • Zen Apprentice
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: Open VPN wont connect after about 4 weeks
« Reply #3 on: May 30, 2019, 11:32:48 am »
royceb - Thank you for the reply. I will work through these steps later. I really appreciate the help.

Milbs1979

  • Zen Apprentice
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: Open VPN wont connect after about 4 weeks
« Reply #4 on: June 04, 2019, 04:47:12 pm »
I worked through he steps and all is working fine now. Resigned and redeployed the certificates to the machines.

Thank you very much for your help.

royceb

  • Guest
Re: Open VPN wont connect after about 4 weeks
« Reply #5 on: June 04, 2019, 09:25:26 pm »
If you can help us find a way to submit this as a ticket/bug i'd think they might push out a change/update

doncamilo

  • Zen Samurai
  • ****
  • Posts: 381
  • Karma: +101/-1
    • View Profile
Re: Open VPN wont connect after about 4 weeks
« Reply #6 on: June 10, 2019, 02:04:05 pm »
Please read this for a useful workaround https://community.spiceworks.com/how_to/158901-how-to-fix-openvpn-zentyal-verify-error-depth-0-error-crl-has-expired-on-ubuntu

It seems it should be fixed on Zentyal 6.1

cheers
"Tanta salud goces como bondad abrigues en tu corazón"

Don Camilo.

"That place... is strong with the
dark side of the Force.  A domain
of evil it is.  In you must go."

Yoda.

Milbs1979

  • Zen Apprentice
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: Open VPN wont connect after about 4 weeks
« Reply #7 on: July 15, 2019, 04:49:38 pm »
Thank you all for your responses and advice. As an update my VPN has been running now for over the 30 day initial period and all is well!!

royceb

  • Guest
Re: Open VPN wont connect after about 4 weeks
« Reply #8 on: March 05, 2020, 05:12:13 am »
RE-Upping this.  Still persistent.  Did a new install on 6.1 and the defaul issue of the 30 - day CRL expiring breaking the entire VPN.