Author Topic: how to trick network configuration  (Read 3939 times)


  • Zen Monk
  • **
  • Posts: 80
  • Karma: +9/-0
    • View Profile
how to trick network configuration
« on: November 04, 2018, 11:13:25 pm »

I have a small problem, getting zentral server running in a virtual environment. Maybe someone can help me out...?

I'm going to use non-routable ip addresses in this "example", just to "mask" the real ip's, so you can ignore the obvious consequences form this, of course.

The virtual machine got an ip like, but the router is only I've tried to set the static ip with net mask, but then zentral will not accept any other gateway at all.
The only way I got it accepted was to assign it with net mask, in order to keep the gateway within range.
So far, so good. somehow awkward, but it works and the remote web admin is accessible.
Now, there's a mirror for updates at, which is in fact non-reachable, due to the fact that apt will try to reach the mirror without using the gateway. I've now tried to set a static route to the mirror via the gateway, but zentral complains that the default gateway is already set.
I can of course set a manual route via console command, but without changing the stubs it will be not permanent.
So, what I wonder now, am I thinking in a wrong way, or is there an issue with the network interfaces setting "rule checks", which will prevent me from setting up the network correctly?

Any ideas on how to overcome this in the best convenient way??

Zentyal 6.1


  • Zen Apprentice
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: how to trick network configuration
« Reply #1 on: January 15, 2019, 06:32:07 am »
Having just begun with Zentyal Server- I am coming strictly from a networking angle (virtual, in this case.)  Since no indication as to the type of virtual environment is given- the following is my advice with what I have to go on:

If you are using a "Host-Only" network adapter type scenario- maybe change the default G/W on the VM network adapter to the IP address of the "Host" adapter. 

Other than that- I've got nothing at the moment