Author Topic: Zentyal 6.0 available!  (Read 911 times)

J. A. Calvo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1985
  • Karma: +66/-2
    • View Profile
    • http://blogs.zentyal.org/jacalvo
Zentyal 6.0 available!
« on: October 30, 2018, 01:14:04 am »
Hi all,

The Zentyal Development Team proudly presents Zentyal 6.0, a new release of the Zentyal Open Source Linux Server with native Active Directory® interoperability.

This release is based on the newest Ubuntu Server 18.04.1 LTS and comes with the latest versions of all the integrated software, starring Linux 4.15 and Samba 4.7. Also, this version introduces the RADIUS and Virtualization Manager modules.

This brand new version is available for download at:

http://www.zentyal.org/download

You can find out all the details in the official announcement:

http://wiki.zentyal.org/wiki/Zentyal_6.0_Announcement

Looking forward to receiving your feedback and comments. More updates will be coming in the next weeks!
Zentyal Server Lead Developer

Sand_man

  • Zen Samurai
  • ****
  • Posts: 264
  • Karma: +15/-0
    • View Profile
Re: Zentyal 6.0 available!
« Reply #1 on: October 30, 2018, 03:59:19 pm »
Congratulations! (I hope ejabber shared roster will work!)

JHOSMAN

  • Zen Apprentice
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: Zentyal 6.0 available!
« Reply #2 on: October 31, 2018, 12:24:24 am »
Hello Good day, I installed Zentyal 6 with the new KVM (Virt), but I do not see how to raise the network, any ideas?

I think, maybe it should be here:



 but I do not see how to associate my LAN network with virtual machines.

Gilberto Ferreira

  • Zen Samurai
  • ****
  • Posts: 497
  • Karma: +12/-1
    • View Profile
Re: Zentyal 6.0 available!
« Reply #3 on: November 05, 2018, 03:19:51 pm »
[ From: https://wiki.zentyal.org/wiki/Zentyal_6.0_Changelog#squid ]
squid
Remove adzapper integration as it is no longer maintained in 18.04
HTTPS block rules are evaluated first and packets are rejected
Group-based user authentication for commercial editions !!!!!!!!!!!!!!!!!!!!!!!!!

Now with need buy commercial edition subscription in order to make squid works with Group-based user auth?
Too bad! =(

mrpsycho

  • Zen Apprentice
  • *
  • Posts: 43
  • Karma: +2/-1
    • View Profile
Re: Zentyal 6.0 available!
« Reply #4 on: November 13, 2018, 12:41:15 pm »
this cool.

project is not abandoned!

but... is there any way to fix broken DNS service?

Neustradamus

  • Zen Monk
  • **
  • Posts: 63
  • Karma: +0/-2
    • View Profile
Re: Zentyal 6.0 available!
« Reply #5 on: November 15, 2018, 01:07:58 am »
mrpsycho: What is the DNS problem exactly?
Please create an issue here: https://github.com/zentyal/zentyal/issues/

mrpsycho

  • Zen Apprentice
  • *
  • Posts: 43
  • Karma: +2/-1
    • View Profile
Re: Zentyal 6.0 available!
« Reply #6 on: November 15, 2018, 01:14:18 pm »

BerT666

  • Zen Warrior
  • ***
  • Posts: 198
  • Karma: +5/-0
    • View Profile
Re: Zentyal 6.0 available!
« Reply #7 on: November 17, 2018, 12:03:10 pm »
looks like you are upgrading to 5.1...?
I remember there was "a hack" with the AppArmor rules to get this away, but I cannot remember which "switches" are the correct ones :-(

When the first Upgrade to z6.0 is done, I can try to check on another server of mine...

Regards

Thomas

BerT666

  • Zen Warrior
  • ***
  • Posts: 198
  • Karma: +5/-0
    • View Profile
Re: Zentyal 6.0 available!
« Reply #8 on: November 17, 2018, 12:09:53 pm »
ubuntu-minimal Updated "kills" the system :-(

Hi, after upgrading to 6.0, I see the package "ubuntu-minimal" has an update...
When installing this, it kills my Server (all Zentyal modules seem to vanish)...

Be careful what you install, and as always: Backup or Snapshot your server!!!

Regards

Thomas

mrpsycho

  • Zen Apprentice
  • *
  • Posts: 43
  • Karma: +2/-1
    • View Profile
Re: Zentyal 6.0 available!
« Reply #9 on: November 19, 2018, 10:47:25 am »
looks like you are upgrading to 5.1...?
I remember there was "a hack" with the AppArmor rules to get this away, but I cannot remember which "switches" are the correct ones :-(

When the first Upgrade to z6.0 is done, I can try to check on another server of mine...

Regards

Thomas


this problem continues from 5.0, it is true.

and this is bad, that for now nobody knows how to fix it. :(

J. A. Calvo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1985
  • Karma: +66/-2
    • View Profile
    • http://blogs.zentyal.org/jacalvo
Re: Zentyal 6.0 available!
« Reply #10 on: November 19, 2018, 11:05:05 am »
The ubuntu-minimal problem is very strange, we can't reproduce it. If we try to upgrade it via commandline or Zentyal UI it fails due to unmet dependencies (as it should be). The solution here to avoid having ubuntu-minimal in the pending system updates list is to remove it with sudo apt purge ubuntu-minimal  (it is an "empty" metapackage anyway so removal won't cause any trouble).

Of course we will publish a new version of the release-upgrade script running the above command automatically so no pending updates appear after upgrading to 6.0. But the thing is, we can't reproduce that "all modules seem to vanish" scenario, so any other information about how you can reach that situation would be very helpful to prevent it from happening.
Zentyal Server Lead Developer

basselope

  • Zen Apprentice
  • *
  • Posts: 22
  • Karma: +1/-0
    • View Profile
Re: Zentyal 6.0 available!
« Reply #11 on: November 19, 2018, 12:01:38 pm »
Hello,

I am using the Development/Community Edition, am on 5.1 and was expecting to see the button to upgrade to 6.0 becoming available any day.

However, after applying updates last week, today I seem to have a new version available, but it is 5.1.2 and not 6.0: "Core version   5.1.1 (5.1.2 available)".

Is this an intermediate step and where do I find info on the changes?

Many thanks

G

Neustradamus

  • Zen Monk
  • **
  • Posts: 63
  • Karma: +0/-2
    • View Profile

Neustradamus

  • Zen Monk
  • **
  • Posts: 63
  • Karma: +0/-2
    • View Profile
Re: Zentyal 6.0 available!
« Reply #13 on: November 19, 2018, 05:40:13 pm »
It is possible to update SMF for block spams etc?

SMF 2.0.15 Released
Mon, 20 Nov 2017 00:47:44 GMT
http://www.simplemachines.org/

Thanks in advance.

Maekar

  • Zen Apprentice
  • *
  • Posts: 39
  • Karma: +0/-0
    • View Profile
Re: Zentyal 6.0 available!
« Reply #14 on: December 04, 2018, 03:06:51 pm »
Hi, where is the data backup module? It appears in 6.0 Documentation but I can't see it in Zentyal: https://doc.zentyal.org/en/backup.html

Is an only-commercial feature now?
« Last Edit: December 04, 2018, 03:10:01 pm by Maekar »