Author Topic: zentyal 5.1 not work all domain users samba  (Read 467 times)

rubicon

  • Zen Apprentice
  • *
  • Posts: 17
  • Karma: +2/-0
    • View Profile
zentyal 5.1 not work all domain users samba
« on: August 31, 2018, 12:05:09 pm »
Greetings. Updated from 5 to 5.1 and lost access to all domain users
I, as an administrator, can not enter the folder and in general neither can anyone except the valid user IgnatovaTV


[Секретарь]
    comment = Секретарь
    path = /home/samba/shares/secretar
    browseable = yes
    force create mode = 0660
    force directory mode = 0660
    valid users = @"All domain users", "IgnatovaTV"
    read list = @"All domain users"
    write list = "IgnatovaTV"
    admin users =.
    vfs objects = acl_xattr full_audit recycle
    full_audit:failure = connect opendir disconnect unlink mkdir rmdir open rename
    recycle: keeptree = Yes
    recycle: versions = Yes
    recycle: directory_mode = 0700
    recycle: inherit_nt_acl = Yes
    recycle: excludedir = /tmp|/var/tmp
    recycle: repository = RecycleBin

When you click on a folder, it requires a password.

What to do?

edoardo

  • Zen Apprentice
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: zentyal 5.1 not work all domain users samba
« Reply #1 on: October 13, 2018, 03:54:57 am »
See https://github.com/zentyal/zentyal/issues/1813.

After I changed /usr/share/perl5/EBox/Samba.pm accordingly to https://github.com/zentyal/zentyal/commit/9142b2fcc520f471680e0dcac23e60d8c7cb450f I rebooted and got Samba working again.

Unfortunately the patch has not been backported to 5.1 yet.