Author Topic: После некорректного обновления не работает админка и половина модулей. Как UP?  (Read 605 times)

IIS

  • Zen Apprentice
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
Имею Zentyal 5.0.1  во время обновления через WEB  интерфейс перегрузили сервер (обрыв питания) после загрузки отвалились web интерфейс и почта. шаринг файлов работает. от большого ума в консоле набрал apt update и apt upgrade
 слилось порядка 300 метров и установилось без ошибок. после рестарта ситуация не изменилась. как востановить работоспасобность!?

luha

  • Zen Samurai
  • ****
  • Posts: 424
  • Karma: +28/-1
    • View Profile
Сделай в консоли:
# nano /etc/apt/sources.list

... пролестай вниз и поправь строку чтобы было:
deb http://archive.zentyal.org/zentyal 5.1 main extra

Сохнанить изменения crtl-x и enter

# apt-get update
# dpkg --configure -a
# apt-get dist-upgrade
# apt-get upgrade -y

Может я тут чего переборщил, но старался чтобы наверняка.

ну и ребутнуть не забыть
« Last Edit: June 04, 2018, 11:47:40 am by luha »

IIS

  • Zen Apprentice
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
Спасибо.
Сервер получил ip по DHCP инета нет. попытка переписать конфиг interface  и перезапуск сетевого интерфейса ни к чему не приводит. 

luha

  • Zen Samurai
  • ****
  • Posts: 424
  • Karma: +28/-1
    • View Profile
А что, у вас через DHCP как-то не правильно настройки рыссылает? Почему нет интернета?

Адреса настраиваются в вебморде и записываются в базе зенчала, при каждом перезапуске перезаписываются из базы. Руками через консоль если править то только шаблоны, но лучше делать в вебморде как и задумано.

В интерфейсах задаёшь IP зенчала (если выбрать static).
В гатвеях задаёшь шлюз в интернет.





IIS

  • Zen Apprentice
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
У меня 2 сервера зенчал: 1й сетевой экран + dhcp сервер на нам для 2го сервера в dhcp  зарезервирован адрес,  до падения он прекрасно получал адрес и инет на нем был.  сейчас веб морда не работает. какой шаблон подправить чтоб статика заработала?

IIS

  • Zen Apprentice
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
У меня 2 сервера зенчал: 1й сетевой экран + dhcp сервер на нам для 2го сервера в dhcp  зарезервирован адрес,  до падения он прекрасно получал адрес и инет на нем был.  сейчас веб морда не работает. какой шаблон подправить чтоб статика заработала?

поправил в ручную resolf.conf инет заработал. ночью попробую обновить.

IIS

  • Zen Apprentice
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
И еще вопрос при обновлении через консоль частенько возникают вопросы какую версию конфигурационного файла оставить?  ту что в системе или из пакета!?  что  выбирать?

luha

  • Zen Samurai
  • ****
  • Posts: 424
  • Karma: +28/-1
    • View Profile
Когда вы писали что не работает интернет как я мог понять что у вас вебморда не доступна? Понял так что уже обновились и с DHCP беда.

Сейчас вы спрашиваете про конфигурационные файлы... я уже не берусь угадывать что вы имеете в виду, уточните.

IIS

  • Zen Apprentice
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
Все большое спасибо!
после обновления все заработало.

IIS

  • Zen Apprentice
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile