Author Topic: Wrong GID on Domain Users group  (Read 900 times)

pgodinic

  • Zen Apprentice
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Wrong GID on Domain Users group
« on: January 22, 2018, 10:54:34 am »
I have problem with wrong gid for group Domain users. Domain users group should have gid 2513, but in my case gid is 100 which is equal to gid of default linux users group. All samba shares don't work.

...
users:x:100:
...
*********\domain admins:x:2512:
*********\domain users:x:100:
*********\domain guests:x:2514:

When i run command "net cache flush" it temporary fix the problem but on next domain user login or logoff the problem reappears again.
On some instalations in /etc/cron.d i have job "zentyal-samba" which runs every minute and runs only command "net cache flush"

zemnet

  • Zen Apprentice
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: Wrong GID on Domain Users group
« Reply #1 on: January 22, 2018, 02:06:47 pm »
Hello,
We have problem with this.

First attention from user is at previous Monday (a week from fresh install), shares don't work, only for home folder.
If I change group owner of samba and shares folders to users (not Domain users), everything work again.

But only into this Monday morning, because after that shares don't work again. I must change owner group of samba and shares to Domain users, after that, work again, but not for all users. After I change owner group back to users (not DU) and users logout and login again, shares will work for every user.

Output of 
"wbinfo --group-info 'DOMAIN\domain users'"
is
"DOMAIN\domain users:x:100:"

Maybe it is same problem.....
Can you help me, server is in production environment....

EDIT:
DOMAIN\administrator:*:0:100::/home/administrator:/bin/bash has root's uid, is that correct? on new fresh install of latest zentyal have different = uid 2500 a gid 2513

EDIT2:
"net cache flush" don't help when group is changed after system reboot or service reboot....
« Last Edit: January 26, 2018, 08:50:14 am by zemnet »

zemnet

  • Zen Apprentice
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: Wrong GID on Domain Users group
« Reply #2 on: February 07, 2018, 02:24:45 pm »
Anybody?  >:(

zemnet

  • Zen Apprentice
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: Wrong GID on Domain Users group
« Reply #3 on: May 02, 2018, 07:14:59 am »
Hi,
I dont know why, but:
once a week GID change to this one automaticaly:

DOMAIN\domain users:x:2513:

but shares work only for half of users.

When I restart server and change shares permission back to "users" group only, everything work fine again.

Can anybody help to solve this problem?

zemnet

  • Zen Apprentice
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: Wrong GID on Domain Users group
« Reply #4 on: May 09, 2018, 07:47:53 am »
After server uptime for 6 days and 23 hours, shares stoped,
and output of

wbinfo --user-info 'DOMAIN\user1'
is
DOMAIN\user1:*:65538:2513::/home/user1:/bin/bash

After restart at 6:20am everything work over DOMAIN USERS group.
Output of "getent passwd" is

DOMAIN\zentyal-mailfilter-server:*:3000019:2513::/home/zentyal-mailfilter-server:/bin/bash
DOMAIN\user2:*:65545:2513::/home/user2:/bin/bash
DOMAIN\zentyal-mail-server:*:3000020:2513::/home/zentyal-mail-server:/bin/bash
DOMAIN\user3:*:65561:2513::/home/user3:/bin/bash
DOMAIN\user4:*:65560:2513::/home/user4:/bin/bash
...
DOMAIN\administrator:*:2500:2513::/home/administrator:/bin/bash
DOMAIN\dns-server:*:3000021:2513::/home/dns-server:/bin/bash
DOMAIN\krbtgt:*:3000022:2513::/home/krbtgt:/bin/bash
DOMAIN\guest:*:65534:2513::/home/guest:/bin/bash



And at 7:20am shares stoped working for one user,
output of "getent passwd" is

DOMAIN\zentyal-mailfilter-server:*:3000019:100::/home/zentyal-mailfilter-server:/bin/bash
DOMAIN\user2:*:65545:100::/home/user2:/bin/bash
DOMAIN\zentyal-mail-server:*:3000020:100::/home/zentyal-mail-server:/bin/bash
DOMAIN\user3:*:65561:100::/home/user3:/bin/bash
DOMAIN\user4:*:65560:100::/home/user4:/bin/bash
...
DOMAIN\administrator:*:2500:100::/home/administrator:/bin/bash
DOMAIN\dns-server:*:3000021:100::/home/dns-server:/bin/bash
DOMAIN\krbtgt:*:3000022:100::/home/krbtgt:/bin/bash
DOMAIN\guest:*:65534:100::/home/guest:/bin/bash

wbinfo --user-info 'DOMAIN\user1'
is
DOMAIN\user1:*:65538:100::/home/user1:/bin/bash

Is here anybody, who can help solve this problem?