Author Topic: SOGoTrustProxyAuthentication = YES results in IMAP4 login failed  (Read 744 times)

jmccoy555

  • Zen Apprentice
  • *
  • Posts: 17
  • Karma: +1/-0
    • View Profile
Hello all,

I'm implementing 2FA to strengthen my webmail security using this great project - https://github.com/clems4ever/authelia

Following https://sogo.nu/nc/support/faq/article/how-to-use-webauth-with-sogo-2.html login is working and the user gets passed into the SOGo webmail with access to contacts and calendar, however no emails show as the IMAP login fails as no password is passed, however no password is available as the authentication has been handled before reaching SOGo.

The SOGo logs shows;

Oct 15 12:03:36 sogod [7]: [ERROR] <0x0x56494a8b8b30[NGImap4ConnectionManager]> IMAP4 login failed:
  host=10.10.1.101, user=user@domain.email, pwd=no
  url=imaps://user%40domain.email@10.10.1.101/?tls=YES
  base=(null)
  base-class=(null))
  = <0x0x56494a9ffba0[NGImap4Client]: login=user@domain.email(pwd) socket=<NGActiveSSLSocket[0x0x56494acc7130]: mode=rw address=(null)>>
Oct 15 12:03:36 sogod [7]: <0x56494aba22f0[SOGoMailAccount]:0> renewing imap4 password
Oct 15 12:03:36 sogod [7]: [ERROR] <0x56494aba22f0[SOGoMailAccount]:0> no IMAP4 password available
Oct 15 12:03:36 sogod [7]: [ERROR] <0x56494aba22f0[SOGoMailAccount]:0> Could not connect IMAP4

And in the mail.log

Oct 15 12:07:29 zentyal dovecot: imap-login: Disconnected (auth failed, 1 attempts in 2 secs): user=<user@domail.email>, method=PLAIN, rip=10.10.1.105, lip=10.10.1.101, TLS: Disconnected, session=<qFww5ZNbUgAKCgFp>
Oct 15 12:07:32 zentyal dovecot: imap(user@domain.email): Disconnected: Logged out in=24114 out=752986

Any ideas if it's possible to authenticate dovecote with just the username etc?

Thanks.