Author Topic: masquerade_domains option not configurable  (Read 500 times)

jstammi

  • Zen Apprentice
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
masquerade_domains option not configurable
« on: May 10, 2017, 11:40:20 am »
Hi,


AFAIS/AFAIK for my use-case I depend on being able to specify the postfix masquerade_domains option. This is not available directly in zentyal. As workaround I appended such to /usr/share/zentyal/stubs/mail/main.cf.mas and things are working now as expected.

But may be I miss something - perhaps some expert may suggest a different solution?


The setup is as follows:

I run a private mail server for my family, all mails arriving to the various mail accounts are collected bwo fetchmail and made accessible (and archived) there, in our private home LAN.

We own a domain and my families members own a related email addresses (not only my own family but also relatives). For some reasons (mailbox sizes, SPAM filtering, etc) mails to those get forwarded elsewhere only (where they get later fetchmail'ed then for the members of my very own family).

Thus our private LAN mailserver is not the master mail server for that domain, it is not addressed as MX for our domain.

On sending mails all of us use an email address belonging to our domain. The private LAN postfix relays mails sent locally to the provider running our domain at.


Unfortunately it seems impossible to seup zentyal mail/webmail accordingly with standard means.


The solution suggested most (and being documented to be the upgrade path from zentyal 3 to 4 where the masquerade_domains option is said to having been removed) is to configure zentyal mail virtual domain to use our domain: sending emails (using the webmail) locally to my own family's members works as expected. But mails to relatives using also an address of our domain are rejected - they needed to be relay'ed but as my private mail server now feels responsible for the domain they don't get.

Instead I configure zentyal mail virtual domain to use a local domain: sending emails to local recipients works, too. Mails (using the webmail) to relatives and other externals get relay'ed. Unfortunately the domain ISP rejects them as they arrive with my local domain based email address.
This get's solved with configuring the masquerade_domains option.


Is there any other option that I'm not aware of, yet?