Author Topic: [SOLVED] Administrator and root email/alias  (Read 870 times)

haychis

  • Zen Apprentice
  • *
  • Posts: 24
  • Karma: +0/-0
    • View Profile
[SOLVED] Administrator and root email/alias
« on: May 05, 2017, 05:42:19 pm »
I can't seem to get administrator and root emails to forward to a virtual domain address.

I've tried /etc/aliases root: henry@virt.domain then newaliases doesn't seem to work
I've tried .forward in /root and /home/administrator with henry@virt.domain doesn't work

I keep getting a message in the log about a bounced message (user unknown) administrator@zentyal.virt.domain. Do I add an email address to the administrator account from 'Users and Computers' ? When I look in there it says 'This user has a mail account which does not belong to any managed mail domain' but can't see any email listed which I suppose is the built in administrator@'server mailname'.

Any help appreciated.

zentyal 5
mail module 5.0.5

« Last Edit: June 10, 2017, 04:37:03 am by haychis »

Laurent Dinclaux

  • Zen Monk
  • **
  • Posts: 80
  • Karma: +4/-0
    • View Profile
    • Gecka
Re: Administrator and root email/alias
« Reply #1 on: May 29, 2017, 02:34:27 am »
I face the same issue :(
Laurent

J. A. Calvo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1986
  • Karma: +67/-3
    • View Profile
    • http://blogs.zentyal.org/jacalvo
Re: Administrator and root email/alias
« Reply #2 on: May 29, 2017, 07:06:31 pm »
Could you please try with the new zentyal-mail 5.0.6? Thanks!
Zentyal Server Lead Developer

haychis

  • Zen Apprentice
  • *
  • Posts: 24
  • Karma: +0/-0
    • View Profile
Re: Administrator and root email/alias
« Reply #3 on: June 10, 2017, 04:16:43 am »
I fixed it by adding hash:/etc/aliases to virtual_aliases_maps.

I will remove it from the mail stub and update to 5.06 and see if that fixes it too.


EDIT: Upgraded to 5.06 and so far working fine. Will mark it solved.
« Last Edit: June 10, 2017, 04:33:01 am by haychis »