Author Topic: KINIT Error on Development 5.0.1  (Read 710 times)

ryanschreiber

  • Zen Apprentice
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
KINIT Error on Development 5.0.1
« on: December 22, 2016, 10:40:00 am »
Hi,

Does anyone know what would be causing this error :

2016/12/22 13:28:26 ERROR> GlobalImpl.pm:659 EBox::GlobalImpl::saveAllModules - Failed to save changes in module samba: root command kinit -e arcfour-hmac-md5 --password-file='/var/lib/zentyal/tmp/RazYC5' 'administrator@DOMAIN.COM' failed.

When i run the command from above, manually at the CLI i get the following response:
kinit: Failed to open the password file /var/lib/zentyal/tmp/RazYC5

Naturally i checked directory permissions and tested it again after running chmod 777 on the directory described, with the same result.
I checked if the file exists which it doesn't so Im not sure if it is being created and deleted.

Not sure where to start hunting this done, any help for which logs to look into would be appreciated

** update

sorry i forgot to add context. whn i try to add zentyal as an additional domain controller and save the settings I get the samba error message
« Last Edit: December 22, 2016, 10:43:33 am by ryanschreiber »

mike59999

  • Zen Apprentice
  • *
  • Posts: 23
  • Karma: +1/-0
    • View Profile
Re: KINIT Error on Development 5.0.1
« Reply #1 on: December 22, 2016, 01:49:14 pm »
Hi,

i had the same problem. Can you take a look in the zentyal.log there should be a reason why the error occours.
The message should be 2 or 3 lines above the message you posted.