Author Topic: Apache is very slow in ebox 1.5  (Read 2702 times)

Alex Assis

  • Zen Apprentice
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
Apache is very slow in ebox 1.5
« on: July 26, 2010, 04:59:10 pm »
Hello,

I'm using Ebox 1.5, I realized that Apache is very slow to respond to requests and also consume much memory and CPU 60%.

My environment:

X3430 Xeon Processor, 2.4 GHz 8M Cache
6 GB memory
250 GB SCSI

Use Apache to display a few pages in HTML and PHP that my company needs to see every day, but with the slow work becomes difficult.



Could anyone help me?

i.e.d.

  • Zen Apprentice
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: Apache is very slow in ebox 1.5
« Reply #1 on: August 04, 2010, 09:13:13 pm »
My setup is much weaker than TS one, but i believe 2 or 3 or sometimes 5 or more minutes of waiting while page loads is too slow. But it happens not every time, about one slow page generation to 3 normal.
According to 'top', i don't see direct relation with free memory while it happens.

I'll try to find out why it happens a bit later, when i finish my initial settings.
Good advises are welcome

J. A. Calvo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1986
  • Karma: +67/-3
    • View Profile
    • http://blogs.zentyal.org/jacalvo
Re: Apache is very slow in ebox 1.5
« Reply #2 on: August 05, 2010, 03:15:46 am »
I think you may see a great performance improvement in the new release that is going to be out in just a few hours... stay tuned!
Zentyal Server Lead Developer

hu76

  • Zen Apprentice
  • *
  • Posts: 27
  • Karma: +0/-0
    • View Profile
Re: Apache is very slow in ebox 1.5
« Reply #3 on: August 05, 2010, 04:32:54 am »
I think you may see a great performance improvement in the new release that is going to be out in just a few hours... stay tuned!

Stay tuned where?

Very frustrating, I've planned my evening to learn fetchmail to attempt to figure out why the External retrieval service won't start.

There's so little communication from the Ebox devs or knowledgeable users in the forums that it makes Ebox almost impossible to use when it fails.

I waited weeks for the release of 2.0 and suddenly it got pushed off another month.

I understand the concept of open source and have read the other threads complaining about releases but the lack of any idea of what's going on is very frustrating.

I really like the ebox layout but I'm starting to think I should just stick with the Ubuntu 10 lts and install the packages I need, forgetting about an overlay from developers that won't communicate.

Sigh, very, very frustrating being kept in the dark.

kmnair

  • Zen Apprentice
  • *
  • Posts: 14
  • Karma: +0/-0
    • View Profile
Re: Apache is very slow in ebox 1.5
« Reply #4 on: August 05, 2010, 07:44:25 am »
Hello HU76,

Stay tuned with Ebox in general. I have been following Ebox for the past two years. I started using it for the past one year when I felt that is stable and feature-rich enough for my use. Calvo has said that there is going to a release immediately. I dont know whether he mans 1.5.9 or higher. Anyway we have to wait.

After all, we do not pay them for the dev, right? If you can opt for the supported versions, you have every right to complain.

As of now, they are doing REALLY wonderful work.

Yes, as you have pointed out, you can stick with LTS10 and proceed.  In fact, that is what I tried when I saw that 1.5 is not stable enough. But I am not a Linux Geek and integration becomes a HELL of a job as the features go up. 

Regards

J. A. Calvo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1986
  • Karma: +67/-3
    • View Profile
    • http://blogs.zentyal.org/jacalvo
Re: Apache is very slow in ebox 1.5
« Reply #5 on: August 05, 2010, 10:16:09 am »

Stay tuned where?


In the forum, or the mailing lists, or following us in twitter, or facebook...

These are the places where new releases are announced ;)
Zentyal Server Lead Developer

J. A. Calvo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1986
  • Karma: +67/-3
    • View Profile
    • http://blogs.zentyal.org/jacalvo
Re: Apache is very slow in ebox 1.5
« Reply #6 on: August 05, 2010, 11:02:22 am »
Zentyal Server Lead Developer

josejad

  • Zen Apprentice
  • *
  • Posts: 48
  • Karma: +1/-0
    • View Profile
Re: Apache is very slow in ebox 1.5
« Reply #7 on: August 06, 2010, 11:26:59 am »
I think this is solved in the 1.5.1 version

i.e.d.

  • Zen Apprentice
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: Apache is very slow in ebox 1.5
« Reply #8 on: August 06, 2010, 09:12:33 pm »
Today i've done upgrade 1.5.8 > 1.5.10 and can confirm that apache runs as fast as i beleive it should do.

J. A. Calvo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1986
  • Karma: +67/-3
    • View Profile
    • http://blogs.zentyal.org/jacalvo
Re: Apache is very slow in ebox 1.5
« Reply #9 on: August 07, 2010, 01:59:24 am »
Today i've done upgrade 1.5.8 > 1.5.10 and can confirm that apache runs as fast as i beleive it should do.

Glad to hear that :) Thanks for the feedback!
Zentyal Server Lead Developer

kmnair

  • Zen Apprentice
  • *
  • Posts: 14
  • Karma: +0/-0
    • View Profile
Re: Apache is very slow in ebox 1.5
« Reply #10 on: August 07, 2010, 09:55:59 am »
Hello,

Installer 1.5-1 gives good performance for Apache. The localhost comes up reasonably fast. But there are other problems in filters. I am opening another post on this.