Author Topic: openchange stoped working  (Read 1177 times)

bragrabb

  • Zen Apprentice
  • *
  • Posts: 13
  • Karma: +0/-0
    • View Profile
openchange stoped working
« on: October 11, 2016, 10:56:14 pm »
Hi there!

I've been hit by a problem - openchange fails to start. I've made no changes (this is true, boy scout honor) myself but after have been  up and running for a year or so openchange suddenly stopped working yesterday. When I try to re-start it via the web console I get this message in /var/log/zentyal/zentyal.log:

2016/10/11 22:42:59 INFO> Service.pm:997 EBox::Module::Service::restartService - Restarting service for module: openchange
2016/10/11 22:43:00 ERROR> MyDBEngine.pm:200 EBox::MyDBEngine::_connect - Connection DB Error: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
2016/10/11 22:43:00 ERROR> Service.pm:1001 EBox::Module::Service::restartService - Error restarting service: Connection DB Error: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
2016/10/11 22:43:00 ERROR> Service.pm:1003 EBox::Module::Service::restartService - Connection DB Error: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
2016/10/11 22:43:00 ERROR> RestartService.pm:61 EBox::SysInfo::CGI::RestartService::_process - Restart of OpenChange from dashboard failed: Connection DB Error: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)

Is there anybody who can point me in the correct direction to find a solution or have any suggestions?

I've had a look at a number of MySQL posts in other forums but since this is not my area of expertise I'm a bit scared I'll mess things up during my quest to improve...  :-)

[Edit] Hmm... Just found out that domain authentification also has stopped working...   :(

Regards
/Mathias

« Last Edit: October 11, 2016, 11:22:18 pm by bragrabb »

mike59999

  • Zen Apprentice
  • *
  • Posts: 23
  • Karma: +1/-0
    • View Profile
Re: openchange stoped working
« Reply #1 on: October 13, 2016, 08:38:28 am »
Hi,

have you checked the state of the MySQL-Server, if not please login over SSH and try "service mysql restart".
If there are erros at the start of the MySQL-Server please post the /var/log/mysql/error.log file.

bragrabb

  • Zen Apprentice
  • *
  • Posts: 13
  • Karma: +0/-0
    • View Profile
Re: openchange stoped working
« Reply #2 on: October 18, 2016, 11:23:06 pm »
Hi Mike!

Thanks for your suggestions!

Here's what's updated in /var/log/mysql/error.log file when I run service mysql restart

   161018 23:00:26 [Note] Server hostname (bind-address): '127.0.0.1'; port: 3306
   161018 23:00:26 [Note]   - '127.0.0.1' resolves to '127.0.0.1';
   161018 23:00:26 [Note] Server socket created on IP: '127.0.0.1'.
   161018 23:00:26 [ERROR] Fatal error: Can't open and lock privilege tables: Can't find file: 'db' (errno: 2)
   161018 23:00:27 [Warning] Using unique option prefix myisam-recover instead of myisam-recover-options is deprecated and will be removed in a future release. Please use the full name instead.
   161018 23:00:27 [Note] Plugin 'FEDERATED' is disabled.
   161018 23:00:27 InnoDB: The InnoDB memory heap is disabled
   161018 23:00:27 InnoDB: Mutexes and rw_locks use GCC atomic builtins
   161018 23:00:27 InnoDB: Compressed tables use zlib 1.2.8
   161018 23:00:27 InnoDB: Using Linux native AIO
   161018 23:00:27 InnoDB: Initializing buffer pool, size = 128.0M
   161018 23:00:27 InnoDB: Completed initialization of buffer pool
   161018 23:00:27 InnoDB: highest supported file format is Barracuda.
   161018 23:00:27  InnoDB: Waiting for the background threads to start
   161018 23:00:28 InnoDB: 5.5.52 started; log sequence number 37450252
   161018 23:00:28 [Note] Server hostname (bind-address): '127.0.0.1'; port: 3306
   161018 23:00:28 [Note]   - '127.0.0.1' resolves to '127.0.0.1';
   161018 23:00:28 [Note] Server socket created on IP: '127.0.0.1'.
   161018 23:00:28 [ERROR] Fatal error: Can't open and lock privilege tables: Can't find file: 'db' (errno: 2)

I've also tried dpkg-reconfigure mysql-server-5.5 but unfortunately the problem is still here.

Well, all suggestions will be well received since I really would like to avoid having to re-install the whole server.

Regards
/Mathias

bragrabb

  • Zen Apprentice
  • *
  • Posts: 13
  • Karma: +0/-0
    • View Profile
Re: openchange stoped working - SOLVED
« Reply #3 on: October 27, 2016, 10:11:52 pm »
Hi there!

After having removed the below files and then issued dpkg --configure mysql-server-5.5 in the folder /var/lib/mysql/ the mysql server whent up again.

Quote
-rw-r--r-- 1 mysql mysql              0 okt 27 21:19 debian-5.5.flag
-rw-rw---- 1 mysql mysql 44040192 okt 27 21:19 ibdata1
-rw-rw---- 1 mysql mysql  5242880 okt 27 21:19 ib_logfile0
-rw-rw---- 1 mysql mysql  5242880 okt 18 22:21 ib_logfile0.old
-rw-rw---- 1 mysql mysql  5242880 okt 18 22:26 ib_logfile1
-rw-rw---- 1 mysql mysql  5242880 okt 18 22:21 ib_logfile1.old

But mind you! To be honest I don't know what these files actually are doing. But new similar files were created after  having issued dpkg --configure mysql-server-5.5.

Now I only need to figure ot why the DNS server will not start. But that will be new topic in a new thread.

Cheers
/Mathias


« Last Edit: October 27, 2016, 10:21:59 pm by bragrabb »

half_life

  • Bug Hunter
  • Zen Hero
  • *****
  • Posts: 862
  • Karma: +58/-0
    • View Profile
Re: openchange stoped working
« Reply #4 on: November 03, 2016, 04:34:16 am »
Those are transaction logs for anything using the innodb engine in mysql.  I see that you kept them by renaming them this is good.  You need to look into recovering innodb tables post abnormal shutdown. 

Good luck! 

bragrabb

  • Zen Apprentice
  • *
  • Posts: 13
  • Karma: +0/-0
    • View Profile
Re: openchange stoped working
« Reply #5 on: November 10, 2016, 08:56:15 pm »
Hi there!

Great, thanks for the feedback! Then I know what to do this weekend...   ::)

Regards
/Mathias