Author Topic: Compiling libsamba-perl ?  (Read 1153 times)

nontrivial

  • Zen Warrior
  • ***
  • Posts: 173
  • Karma: +14/-0
    • View Profile
Compiling libsamba-perl ?
« on: August 22, 2016, 08:59:49 pm »
I provide email support for small medical practices, usually with fewer than 10 users each. Legally (HIPAA) it is much easier to use my own bare metal servers so I have been using Zentyal. As of Zentyal 4.2 32bit architecture is no longer supported. I would like to not have to spend over $2000 US to replace perfectly usable servers. Therefore, after a bit of research, it appears that the only reason Zentyal isn't supported on 32bit machines is because there is no 32bit debian package available for libsamba-perl. So I have been trying to compile it myself from the github source, but I can't get around a compile error. I have gotten around other errors by installing debian packages (libtalloc-dev, samba-dev, etc). But I can't find the right package to eliminate the error below. Any help would be greatly appreciated.

Package samba-security was not found in the pkg-config search path.
Perhaps you should add the directory containing `samba-security.pc'

nontrivial

  • Zen Warrior
  • ***
  • Posts: 173
  • Karma: +14/-0
    • View Profile
Re: Compiling libsamba-perl ?
« Reply #1 on: August 22, 2016, 11:33:37 pm »
After doing a little more investigating it appears as though there are several Zentyal packages that now only come in amd64 versions. So i386 has gone from "unsupported" to "impossible" starting with Zentyal version 4.2. I did manage to install Zentyal 4.1 by first installing Ubuntu 14.04.2 i386 and then installing the Zentyal packages by hand, but only after fighting through a dependency issues that has been fixed for amd64 but not i386. If you want to try the basics are:

 dpkg -i openchange-ocsmanager_2.3-zentyal9_all.deb python-ocsmanager_2.3-zentyal9_all.deb python-mapistore_2.3-zentyal9_i386.deb libmapistore0_2.3-zentyal9_i386.deb
 echo "openchange-ocsmanager hold" | sudo dpkg --set-selections
 echo "python-ocsmanager hold" | sudo dpkg --set-selections)

I am currently evaluating Zentyal 4.1, but I have also started investigating alternatives like mail-in-a-box, iRedMail, Sovereign, and Modoboa. I may end up staying with Zentyal, but I just found out about the lack of i386 support and I hadn't budget replacing most of my servers at once. So if I do stay then it's going to be a few months. Maybe by then the mythical Zentyal 5.0 will be available.

nontrivial

  • Zen Warrior
  • ***
  • Posts: 173
  • Karma: +14/-0
    • View Profile
Re: Compiling libsamba-perl ?
« Reply #2 on: August 26, 2016, 03:36:18 pm »
So, funny story, it turns out my servers are 64bit.