Author Topic: email services never start  (Read 828 times)

ATT1

  • Zen Monk
  • **
  • Posts: 88
  • Karma: +0/-0
    • View Profile
email services never start
« on: April 28, 2016, 03:19:13 pm »
Editing the users email settings in the web interface,  I get a warning:

Quote
"Mail account is unavailable because either there isn't any mail virtual domain created or you need to save changes in order to activate the new domains.
Click here to create a new mail virtual domain"

Okay, so mail is not started, but why?

Trying to start mail:

Quote
root@zentyal-cyprus:~# service zentyal status
Usage: /etc/init.d/zentyal start|stop|restart
       /etc/init.d/zentyal <module> start|stop|status|enabled|restart
root@zentyal-cyprus:~# service zentyal mail status
Zentyal: status module mail:         [ STOPPED ]
root@zentyal-cyprus:~# service zentyal mail start
 * Restarting Zentyal module: mail                                       [fail]
root command set -e
samba-tool domain exportkeytab '/etc/dovecot/dovecot.keytab' --principal 'zentyal-mail-zentyal-cyprus'
samba-tool domain exportkeytab '/etc/dovecot/dovecot.keytab' --principal 'imap/zentyal-cyprus.niotronic.lan'
samba-tool domain exportkeytab '/etc/dovecot/dovecot.keytab' --principal 'imap/zentyal-cyprus.niotronic.lan@NIOTRONIC.LAN'
samba-tool domain exportkeytab '/etc/dovecot/dovecot.keytab' --principal 'smtp/zentyal-cyprus.niotronic.lan'
samba-tool domain exportkeytab '/etc/dovecot/dovecot.keytab' --principal 'smtp/zentyal-cyprus.niotronic.lan@NIOTRONIC.LAN'
samba-tool domain exportkeytab '/etc/dovecot/dovecot.keytab' --principal 'pop/zentyal-cyprus.niotronic.lan'
samba-tool domain exportkeytab '/etc/dovecot/dovecot.keytab' --principal 'pop/zentyal-cyprus.niotronic.lan@NIOTRONIC.LAN'
chown 'root':'dovecot' '/etc/dovecot/dovecot.keytab'
chmod '440' '/etc/dovecot/dovecot.keytab' failed.
Error output: GENSEC backend 'gssapi_spnego' registered
 GENSEC backend 'gssapi_krb5' registered
 GENSEC backend 'gssapi_krb5_sasl' registered
 GENSEC backend 'spnego' registered
 GENSEC backend 'schannel' registered
 GENSEC backend 'naclrpc_as_system' registered
 GENSEC backend 'sasl-EXTERNAL' registered
 GENSEC backend 'ntlmssp' registered
 GENSEC backend 'http_basic' registered
 GENSEC backend 'http_ntlm' registered
 GENSEC backend 'krb5' registered
 GENSEC backend 'fake_gssapi_krb5' registered
 interpret_string_addr_internal: getaddrinfo failed for name eth1 (flags 32) [Name or service not known]
 interpret_interface: Can't find address for eth1
 interpret_string_addr_internal: getaddrinfo failed for name eth1 (flags 32) [Name or service not known]
 interpret_interface: Can't find address for eth1
 ERROR(runtime): uncaught exception - Key table entry not found
   File "/usr/lib/python2.7/dist-packages/samba/netcmd/__init__.py", line 175, in _run
     return self.run(*args, **kwargs)
   File "/usr/lib/python2.7/dist-packages/samba/netcmd/domain.py", line 117, in run
     net.export_keytab(keytab=keytab, principal=principal)

Command output: .
Exit value: 255
root@zentyal-cyprus:~#

That's right, I only need eth0, I have not configured eth1..... but.... why should I ?

What shall I do to get mail to work ?


ATT1

  • Zen Monk
  • **
  • Posts: 88
  • Karma: +0/-0
    • View Profile
Re: email services never start
« Reply #1 on: April 28, 2016, 03:20:02 pm »
I forgot to say: Used system is latest Zentyal 4.2 with all updates....

Edit: Addendum: I found out that it is a very bad idea on Zentyal 4.2 to do " samba-tool domain provision" again.
The reprovisioning seems to mess up some database, the result of this will be that the users corner is suddenly gone, possibly due to a corrupted database, and the only way to clear up this mess is to re-install Zentyal, so far.
« Last Edit: May 01, 2016, 12:16:45 pm by ATT1 »