Author Topic: Version 3.5 missing  (Read 2157 times)

zaber

  • Zen Apprentice
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Version 3.5 missing
« on: April 19, 2016, 04:23:54 pm »
Hello all,
    I stayed on version 3.5 for the radius package.  Last night I started receiving errors that I couldn't log into my email.  When I investigated it appears that samba is no longer in my system and cannot be installed because of unresolved dependencies.  When I look at the package files in the Zentyal repositories for 3.5 they are empty.  does anyone have any idea what is going on?

zaber

  • Zen Apprentice
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: Version 3.5 missing
« Reply #1 on: April 19, 2016, 04:29:22 pm »
After doing a little more digging the package file once again has data in it, and I am now finding this message: "samba-libs : Depends: libldb1 (< 1:1.1.17~) but 1:1.1.24-0ubuntu0.14.04.1 is to be installed"

julio

  • Guest
Re: Version 3.5 missing
« Reply #2 on: April 20, 2016, 03:58:33 pm »
i got the same problem, zentyal-samba module "easy" reinstall inpossible!

@Developers: i know this "Product" are not supported anymore, but please don't destroy the runnig systems with wrong/missing dependencies!!!
« Last Edit: April 20, 2016, 04:09:32 pm by julio »

zaber

  • Zen Apprentice
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: Version 3.5 missing
« Reply #3 on: April 20, 2016, 06:41:18 pm »
Well, for anyone interested I "fixed" my system up upgrading the version of Zentyal.  Unfortunately I also lost the Radius module which I was using, and cannot consider this issue solved.


Dezsike

  • Zen Apprentice
  • *
  • Posts: 7
  • Karma: +1/-0
    • View Profile
Re: Version 3.5 missing
« Reply #4 on: April 21, 2016, 10:53:01 am »
I had exactly the same problem. I did a fresh install of 4.2 which solved it. You can configure freeradius manually after upgrading, just copy the config files from your broken system and create the LDAP user in the new one (or take the user from the mail module config and use that, it should work aswell). Clients may complain about wrong certificates but should authenticate.

julio

  • Guest
Re: Version 3.5 missing
« Reply #5 on: April 21, 2016, 11:39:13 am »
I had exactly the same problem. I did a fresh install of 4.2 which solved it. You can configure freeradius manually after upgrading, just copy the config files from your broken system and create the LDAP user in the new one (or take the user from the mail module config and use that, it should work aswell). Clients may complain about wrong certificates but should authenticate.

you are right, but i don't want this production server (3.5) to 4.0/4.1/4.2 upgrading!
my problem is the philosophy, why destroying the developers running 3.5 systems, with wrong/missing dependencies??

zaber

  • Zen Apprentice
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: Version 3.5 missing
« Reply #6 on: April 21, 2016, 05:21:47 pm »
Quote
you are right, but i don't want this production server (3.5) to 4.0/4.1/4.2 upgrading!
my problem is the philosophy, why destroying the developers running 3.5 systems, with wrong/missing dependencies??

I think an Ubuntu package superseded one that Zentyal needed.  Unfortunately as this is my home server I could not devote much time to fixing it, but still needed it running.  All I know is that everything that depended on samba was gone and we could not get emails or use our wireless.  I will have to swing around and manually configure radius at a later time.

I wish the Zentyal team kept their focus as a Microsoft SBS replacement instead of focusing on Exchange. 

julio

  • Guest
Re: Version 3.5 missing
« Reply #7 on: April 21, 2016, 06:30:10 pm »
Quote
you are right, but i don't want this production server (3.5) to 4.0/4.1/4.2 upgrading!
my problem is the philosophy, why destroying the developers running 3.5 systems, with wrong/missing dependencies??

I think an Ubuntu package superseded one that Zentyal needed.  Unfortunately as this is my home server I could not devote much time to fixing it, but still needed it running.  All I know is that everything that depended on samba was gone and we could not get emails or use our wireless.  I will have to swing around and manually configure radius at a later time.

I wish the Zentyal team kept their focus as a Microsoft SBS replacement instead of focusing on Exchange.

libldb1 and samba-libs is not Ubuntu package, its coming from Zentyal pool:
http://archive.zentyal.org/zentyal/pool/main/l/ldb/
http://archive.zentyal.org/zentyal/pool/main/s/samba/

That is my problem, developers why don't care about this??
First i386 packages dependency and now the amd64 versions??
Or not supported versions means: destroying all other running older (<4.2) versions??



zaber

  • Zen Apprentice
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: Version 3.5 missing
« Reply #8 on: April 21, 2016, 08:09:20 pm »
Quote
libldb1 and samba-libs is not Ubuntu package, its coming from Zentyal pool:
http://archive.zentyal.org/zentyal/pool/main/l/ldb/
http://archive.zentyal.org/zentyal/pool/main/s/samba/

That's odd, when I checked the only versions of libldb1 were in ubuntu main and backports.  The package is not listed in 'http://archive.zentyal.org/zentyal/dists/3.5/main/binary-amd64/Packages'  What kepd screwing me up was samba-libs with the following dependencies: " libldb1 (<< 1:1.1.17~), libldb1 (>> 1:1.1.16~)"

Assuming I understand the way apt works correctly.

julio

  • Guest
Re: Version 3.5 missing
« Reply #9 on: April 21, 2016, 09:13:49 pm »
Quote
libldb1 and samba-libs is not Ubuntu package, its coming from Zentyal pool:
http://archive.zentyal.org/zentyal/pool/main/l/ldb/
http://archive.zentyal.org/zentyal/pool/main/s/samba/

That's odd, when I checked the only versions of libldb1 were in ubuntu main and backports.  The package is not listed in 'http://archive.zentyal.org/zentyal/dists/3.5/main/binary-amd64/Packages'  What kepd screwing me up was samba-libs with the following dependencies: " libldb1 (<< 1:1.1.17~), libldb1 (>> 1:1.1.16~)"

Assuming I understand the way apt works correctly.

yes over apt works correctly because this packages status: keept back.
but the GUI and the zentyal scheduled auto update can't handle the packages keep status => you system destroyed...
« Last Edit: April 21, 2016, 09:34:28 pm by julio »

Bill H

  • Zen Apprentice
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: Version 3.5 missing
« Reply #10 on: April 26, 2016, 01:45:28 am »
I am fairly new to this, but this is what I found

You need to revert to earlier versions of ldb-tools libldb1 and python-ldb   See- https://tracker.zentyal.org/issues/2505
This part is quoted from the tracker--
 You need to downgrade the packages incorrectly installed. For doing this please, check that this three packages
ldb-tools  libldb1   python-ldb

Are in version 1:1.1.16-1 instead of version 1:1.1.17-1

How to force the downgrade?
sudo apt-get install $PACKAGE_NAME=1:1.1.16-1

Doing that for the three packages should solve your problems.
That also means that you can't update these three packages again.

julio

  • Guest
Re: Version 3.5 missing
« Reply #11 on: April 26, 2016, 11:12:29 am »
I am fairly new to this, but this is what I found

You need to revert to earlier versions of ldb-tools libldb1 and python-ldb   See- https://tracker.zentyal.org/issues/2505
This part is quoted from the tracker--
 You need to downgrade the packages incorrectly installed. For doing this please, check that this three packages
ldb-tools  libldb1   python-ldb

Are in version 1:1.1.16-1 instead of version 1:1.1.17-1

How to force the downgrade?
sudo apt-get install $PACKAGE_NAME=1:1.1.16-1

Doing that for the three packages should solve your problems.
That also means that you can't update these three packages again.

thanks for your suggestion, but if you update the ldb-tools and libldb1 over GUI,
its remove the zentyal-samba and zentyal-squid pakages!!!
If you try reinstall this two zentyal modules,
zentyal-samba have another unresolved dependencies!

Code: [Select]
sudo apt-get install zentyal-samba zentyal-squid

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 zentyal-samba : Depends: libsamba-perl (>= 0.11~1) but it is not going to be installed
                 Depends: samba (>= 2:4.1.6) but it is not going to be installed
                 Depends: samba-vfs-modules but it is not going to be installed
                 Depends: sssd
E: Unable to correct problems, you have held broken packages.

For all zentyal 3.5 users: don't use the zentyal GUI for system update or install/remove zentyal modules!!!

zaber

  • Zen Apprentice
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: Version 3.5 missing
« Reply #12 on: April 26, 2016, 04:38:27 pm »
Quote
thanks for your suggestion, but if you update the ldb-tools and libldb1 over GUI,
its remove the zentyal-samba and zentyal-squid pakages!!!
If you try reinstall this two zentyal modules,
zentyal-samba have another unresolved dependencies!

This is exactly what happened to me.  When I get some time I will be looking into a replacement for Zentyal as it has diverged too far from what I needed it for.

Don

peptoniET

  • Zen Apprentice
  • *
  • Posts: 27
  • Karma: +4/-0
    • View Profile
Re: Version 3.5 missing
« Reply #13 on: May 02, 2016, 10:30:56 am »
Had the same problem with upgrading a 3.5 system yesterday.  Samba and Zentyal "Users, computers y file sharing" module had vanished from the system.

I was able to install zentyal-samba after doing the two following actions:

apt-get install libldb1=1:1.1.16-1
apt-get install python-ldb=1:1.1.16-1

Of course, you need to uninstall any previous versions.

Hope it helps, I was a whole hour running after this, while my client was unable to work at all.

julio

  • Guest
Re: Version 3.5 missing
« Reply #14 on: May 02, 2016, 10:48:59 am »
thanks for your suggestion, but if you remove the samba package,
Code: [Select]
sudo apt-get purge --auto-remove zentyal-sambayou can't (easy) reinstall them back!

becouse:
Code: [Select]
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 zentyal-samba : Depends: libsamba-perl (>= 0.11~1) but it is not going to be installed
                 Depends: samba (>= 2:4.1.6) but it is not going to be installed
                 Depends: samba-vfs-modules but it is not going to be installed
                 Depends: sssd
E: Unable to correct problems, you have held broken packages.
« Last Edit: May 02, 2016, 11:20:41 am by julio »