Author Topic: Openchange-Server is not reachable (constantly)  (Read 2326 times)


  • Zen Apprentice
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Openchange-Server is not reachable (constantly)
« on: February 10, 2016, 07:29:00 pm »
Hello everybody,

I am trying to use Zentyal as new Groupware-Server. But it's rarely more then trying. Outlook 2016 didn't work with openchange. Ive tried a lot with autidiscover --> no succcess. So ein decided to use Outlook 2013. This should work. I've tried Several times and finaly, Openchange seems to work with Outlook 2013. But only for an hour or so. After a very short period of using (it is so short, you can't name it using) Outlook claims: Server not reachable/available.
Where are my Errors?
I'm using the latest Zentyal on a intel2cor Duo-Server. DHCP and the Firewall are not in use. My PCs (Win8.1) are not in the Domain (there are no plans to do so). Openchange seems to be very "fragile" to me. In my distress I tried everything I can find in forums and I can think of. I deactivated the NAT-Filter of my router as well with no success!

What is to do? Some Ideas?



  • Zen Apprentice
  • *
  • Posts: 7
  • Karma: +1/-0
    • View Profile
Re: Openchange-Server is not reachable (constantly)
« Reply #1 on: March 10, 2016, 08:51:15 pm »
Hello Florian,

I had the same problem with my first zentyal installation. Openchange got over the course of a week slower and slower until it immediately crashed when there was some load on (With load I mean one web interface instance running).

Apparently, after reinstalling, openchange is faster, however it is still very slow (the webinterface takes sometimes over 2 minutes to completly load (in lan)) and crashes sometimes (~2 times a month). The solution for the crashing was a cronjob which sends a start command to the zentyal-openchange service hourly.

Outlook (2016) still also shows the server down a lot however not all the time. Receiving mails in outlook however even works when the server is shown down. I came around this by using imap instead. Strangely, on a virtual machine (2 cores of my Intel i5-3317U mobile, 1,5GB DDR3) I sat up for testing before changing something on my production server, I don`t have any speed issues. I´m aware that the server has to handle a lot more tasks (dhcp, dns, users, samba filesharing, cups, webmin) than the virtual machine (only openchange and users). However, I´m running less than 10 users (it´s a private server) on a Intel Xeon E3-1230 with 8GB DDR3 and a 250GB Samsung SSD as the system drive so speed issues with this configuration should not happen. Also the CPU load is below 1.0 and I´m barely using a quarter of the available ram.

I haven´t tried any other machines but maybe openchange has problems with different types of cpus?