Author Topic: Openchange not reading stubs  (Read 1377 times)

trysomething

  • Zen Warrior
  • ***
  • Posts: 119
  • Karma: +5/-0
  • Founder of The Tiki Lab
    • View Profile
    • The Tiki Lab | Bridging the gap between technology and vision impairment!
Openchange not reading stubs
« on: February 02, 2016, 07:35:52 pm »
I'm working on a Zentyal 4.2 server and Openchange/Samba/Sogo have all been testing my patience for a while now.  Most recently I reslved my Samba crashes and realized that Openchange was still being goofy so I deleted out my custom stub under /etc/Zentyal/stubs/openchange/apache-ocsmanager.conf.mas and restarted the server.  Ironically nothing changed, so I remembered that I'd made a backup of the original stub /usr/share/Zentyal/stubs, edited the original and then just copied the edited version over so I undid that and everything worked as expected.
Once I had that I figured that having the same file in both spots was maybe a problem so I just copied the original over to /etc/Zentyal/stubs/openchange and edited it directly leaving the original in pristine condition.  Restarting Openchange didn't make a difference so I restarted the whole server and still nothing changed.
I went into the original file /usr/share/Zentyal/stubs/openchange/apache-ocsmanager.conf.mas and made the changes, then restarted Openchange and it stuck this time.
I'm also having some authentication issues, when I setup an Outlook client I have to go into the settings and set Outlook to always prompt for logon credentials.  This works at about 75% of what it "should" be because I ended up having to configure the Send/Receive Groups in Outlook too.  These are all based on older posts, old bug reports with the "Solved" status and all of them are based on something that was previously fixed in an update.
My server is 100% up to date.
I even opened up all ports on my Zentyal Firewall and dropped the server into the DMZ last night to run some tests on it.  Somehow it seems like Openchange is just out to get me...
Anyone ever find anything like this happening?  If so did anyone ever come up with a fix for it?
Any help is super appreciated!
You will have to excuse my posts not having actual links in them.  I'm blind and can never find that insert hyperlink button LoL.  If you, or someone you know has vision problems check out The Tiki Lab.

jbahillo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1444
  • Karma: +77/-2
    • View Profile
Re: Openchange not reading stubs
« Reply #1 on: February 03, 2016, 11:12:18 am »
Hello:

Proper place for stubs customizations is /etc/zentyal/stubs/<module>/<masfile>

If this is not working for you, then I would suggest:

1. enable debug at /etc/zentyal/zentyal.conf
2. restart webadmin module: service zentyal webadmin restart
3. Monitor /var/log/zentyal/zentyal.log while module is being restarted

trysomething

  • Zen Warrior
  • ***
  • Posts: 119
  • Karma: +5/-0
  • Founder of The Tiki Lab
    • View Profile
    • The Tiki Lab | Bridging the gap between technology and vision impairment!
Re: Openchange not reading stubs
« Reply #2 on: February 03, 2016, 08:23:44 pm »
Thanks for the info, all I got was the following:

2016/02/03 10:58:38 DEBUG> Sudo.pm:189 EBox::Sudo::_root - /etc/init.d/zentyal webadmin restart (pid: 18289) - /sbin/status 'ebox.redis'
2016/02/03 10:58:38 INFO> Service.pm:997 EBox::Module::Service::restartService - Restarting service for module: webadmin
2016/02/03 10:58:41 DEBUG> Sudo.pm:189 EBox::Sudo::_root - /etc/init.d/zentyal webadmin restart (pid: 18289) - set -e
/bin/mv /var/lib/zentyal/tmp/hcNFDE_HI9 '/var/lib/zentyal/conf/nginx.conf'
/bin/chmod 0644 '/var/lib/zentyal/conf/nginx.conf'
/bin/chown ebox.ebox '/var/lib/zentyal/conf/nginx.conf'
2016/02/03 10:58:41 DEBUG> Sudo.pm:189 EBox::Sudo::_root - /etc/init.d/zentyal webadmin restart (pid: 18289) - set -e
/bin/mv /var/lib/zentyal/tmp/yM2XRAFujq '/etc/init/zentyal.webadmin-nginx.conf'
/bin/chmod 0644 '/etc/init/zentyal.webadmin-nginx.conf'
/bin/chown 0.0 '/etc/init/zentyal.webadmin-nginx.conf'
2016/02/03 10:58:41 DEBUG> Sudo.pm:189 EBox::Sudo::_root - /etc/init.d/zentyal webadmin restart (pid: 18289) - set -e
/bin/mv /var/lib/zentyal/tmp/rsrXO1ja0K '/etc/init/zentyal.webadmin-uwsgi.conf'
/bin/chmod 0644 '/etc/init/zentyal.webadmin-uwsgi.conf'
/bin/chown 0.0 '/etc/init/zentyal.webadmin-uwsgi.conf'
2016/02/03 10:58:41 DEBUG> Sudo.pm:189 EBox::Sudo::_root - /etc/init.d/zentyal webadmin restart (pid: 18289) - set -e
/bin/mv /var/lib/zentyal/tmp/yKxajTr0mZ '/var/lib/zentyal/dynamicwww//css/public.css'
/bin/chmod 0644 '/var/lib/zentyal/dynamicwww//css/public.css'
/bin/chown 107.113 '/var/lib/zentyal/dynamicwww//css/public.css'
2016/02/03 10:58:41 DEBUG> Sudo.pm:189 EBox::Sudo::_root - /etc/init.d/zentyal webadmin restart (pid: 18289) - set -e
/bin/mv /var/lib/zentyal/tmp/4a_iDeeKwY '/var/lib/zentyal/dynamicwww//css/login.css'
/bin/chmod 0644 '/var/lib/zentyal/dynamicwww//css/login.css'
/bin/chown 107.113 '/var/lib/zentyal/dynamicwww//css/login.css'
2016/02/03 10:58:41 DEBUG> Sudo.pm:189 EBox::Sudo::_root - /etc/init.d/zentyal webadmin restart (pid: 18289) - set -e
/bin/mv /var/lib/zentyal/tmp/r1DgOKKxYk '/usr/share/zentyal/www//css/jquery-ui/jquery-ui.css'
/bin/chmod 0644 '/usr/share/zentyal/www//css/jquery-ui/jquery-ui.css'
/bin/chown 107.113 '/usr/share/zentyal/www//css/jquery-ui/jquery-ui.css'
2016/02/03 10:58:41 DEBUG> Sudo.pm:189 EBox::Sudo::_root - /etc/init.d/zentyal webadmin restart (pid: 18289) - rm -f /var/lib/zentyal/tmp/webadmin_no_restart_on_trigger
2016/02/03 10:58:42 DEBUG> Sudo.pm:189 EBox::Sudo::_root - /etc/init.d/zentyal webadmin restart (pid: 18289) - sed -i 's/^enabled=.*/enabled=1/' /etc/default/apport
2016/02/03 10:58:42 DEBUG> Sudo.pm:189 EBox::Sudo::_root - /etc/init.d/zentyal webadmin restart (pid: 18289) - /sbin/status 'zentyal.webadmin-uwsgi'
2016/02/03 10:58:42 DEBUG> Sudo.pm:189 EBox::Sudo::_root - /etc/init.d/zentyal webadmin restart (pid: 18289) - /sbin/stop 'zentyal.webadmin-uwsgi'
2016/02/03 10:58:42 DEBUG> Sudo.pm:189 EBox::Sudo::_root - /etc/init.d/zentyal webadmin restart (pid: 18289) - /sbin/start 'zentyal.webadmin-uwsgi'
2016/02/03 10:58:42 DEBUG> Sudo.pm:189 EBox::Sudo::_root - /etc/init.d/zentyal webadmin restart (pid: 18289) - /sbin/status 'zentyal.webadmin-nginx'
2016/02/03 10:58:42 DEBUG> Sudo.pm:189 EBox::Sudo::_root - /etc/init.d/zentyal webadmin restart (pid: 18289) - /sbin/stop 'zentyal.webadmin-nginx'
2016/02/03 10:58:42 DEBUG> Sudo.pm:189 EBox::Sudo::_root - /etc/init.d/zentyal webadmin restart (pid: 18289) - /sbin/start 'zentyal.webadmin-nginx'
2016/02/03 10:58:42 DEBUG> Sudo.pm:189 EBox::Sudo::_root - /etc/init.d/zentyal webadmin restart (pid: 18289) - service apport restart

It doesn't look like anything is wrong though.  Do you know if there is a way to drop the first bunch of characters when reading a log though?  I'm blind so I use a screen reader and hearing the first hundred or so things for every line is mind numbing at best LoL. 
Should I restart Openchange and check the Zentyal.log again?
For the record I did have apache-ocsmanager.conf.mas inside of /etc/Zentyal/stubs/openchange and I've even made certain that all permissions matched exactly as they do in /usr/share/Zentyal/stubs/* for any stub I've created.
Just to make sure I was crazy I dropped some invalid lines of code into the custom stub and restarted Openchange without error, I then moved the horribly wrong file into the /usr/share/Zentyal/stubs/openchange directory and restarted with a failure.
Any more suggestions or help is greatly appreciated.
Thank you again :)
You will have to excuse my posts not having actual links in them.  I'm blind and can never find that insert hyperlink button LoL.  If you, or someone you know has vision problems check out The Tiki Lab.

jbahillo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1444
  • Karma: +77/-2
    • View Profile
Re: Openchange not reading stubs
« Reply #3 on: February 04, 2016, 02:47:19 pm »

Should I restart Openchange and check the Zentyal.log again?


That's what my step 3 intended to say

jbahillo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1444
  • Karma: +77/-2
    • View Profile
Re: Openchange not reading stubs
« Reply #4 on: February 05, 2016, 01:33:00 pm »
Hello:

In addition please make sure that both /etc/zentyal /etc/zentyal/stubs and /etc/zentyal/stubs/openchange folders have 'others' execution permission, If they don't just run chmod o+x for every one of them