Author Topic: Issue Pushing Group Policy to Windows Client  (Read 3514 times)


  • Zen Apprentice
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Issue Pushing Group Policy to Windows Client
« on: December 01, 2015, 09:33:56 pm »
I 'am running Zentyal 4.2 as a PDC and able to connect windows client however whilst applying group policies to users & groups I have observed that very few policies are getting through and rest are not getting updated at the client end.

> I have tried multiple users on multiple system
> Tried gpupdate /force command as well
> Tried rebooting both the machines

But all in vain, any help would be greatly appreciated. I believe there's some communication issue between windows/zentyal :(


  • Zen Apprentice
  • *
  • Posts: 3
  • Karma: +1/-0
    • View Profile
Re: Issue Pushing Group Policy to Windows Client
« Reply #1 on: December 02, 2015, 05:04:34 pm »
I had a lot of trouble with this too.  In my case it turned out to be a combination of things.  First, make sure your users are in the correct OU for the policies.  Also, check the security filtering to make sure the policies apply to the right groups.  Use the group policy results tool in the Group Policy Management Console to make sure the policies are applied in the way you expect.

You said Zentyal was the PDC.  Do you have additional domain controllers?  If so, make sure replication is working:
samba-tool drs showrepl

I ended up having to set up a cron job to restart the replication service (samba-ad-dc) hourly before it would work reliably.

Also, read the logs on the clients to see if there are any errors.