Author Topic: Zentyal to Zentyal VPN link up, advertised network not work.  (Read 1082 times)

imagineer

  • Zen Apprentice
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Zentyal to Zentyal VPN link up, advertised network not work.
« on: November 25, 2015, 09:08:02 pm »
I have a problem with connecting 2 offices across the internet. I have setup 2 new servers zentyal to zentyal. 1 is the main server, which is also a web mail and file server, the other is a slave. But I can't get the vpn to work, I've been tearing my hair out. I've found similar problems on these forums and I think I need to modify some tables but I'm not sure what the problem is. I can't resolve 192.168.160.0  to 192.168.0.0, the advertised network not work. I've tried tun and tap, firewall rules, staic routes, L2TP. All to no avail.

here's a copy of the routing table

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.0.0     0.0.0.0         255.255.255.0   U     0      0        0 eth1
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
192.168.160.0   0.0.0.0         255.255.255.0   U     0      0        0 tap0
220.233.1.xxx   0.0.0.0         255.255.255.255 UH    0      0        0 ppp0


and ifconfig


eth0      Link encap:Ethernet  HWaddr 30:b5:c2:04:cd:bd 
          inet addr:192.168.1.2  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:48 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:5280 (5.2 KB)

eth1      Link encap:Ethernet  HWaddr 1c:87:2c:63:9b:82 
          inet addr:192.168.0.1  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:109939 errors:0 dropped:2 overruns:0 frame:0
          TX packets:22180 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:14608718 (14.6 MB)  TX bytes:6439430 (6.4 MB)

eth2      Link encap:Ethernet  HWaddr c0:4a:00:04:c2:4e 
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:108711 errors:0 dropped:0 overruns:0 frame:0
          TX packets:129475 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:33269463 (33.2 MB)  TX bytes:34492395 (34.4 MB)

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:333968 errors:0 dropped:0 overruns:0 frame:0
          TX packets:333968 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:65222856 (65.2 MB)  TX bytes:65222856 (65.2 MB)

ppp0      Link encap:Point-to-Point Protocol 
          inet addr:220.233.19x.xxx  P-t-P:220.233.x.xxx  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
          RX packets:82903 errors:0 dropped:0 overruns:0 frame:0
          TX packets:101298 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:22867143 (22.8 MB)  TX bytes:23673115 (23.6 MB)

tap0      Link encap:Ethernet  HWaddr 6e:ac:4d:c3:f4:fd 
          inet addr:192.168.160.1  Bcast:192.168.160.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:27 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:0 (0.0 B)  TX bytes:2202 (2.2 KB)

I've added the vpn firewall rules internal and external.
can anyone help me?

imagineer

  • Zen Apprentice
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Zentyal to Zentyal VPN link up, advertised network not work.
« Reply #1 on: November 28, 2015, 03:26:19 am »
I have solved the issue. It seems its not well documented (if at all) but both ends need to be on a different subnet. I had been under the impression they would work on the same subnet, so that’s how I set it up. 3 days lost in frustration. :) I won't do that again! https://forum.zentyal.org/Smileys/default/smiley.gif