Author Topic: 4.2.1.1 DNS Configuration  (Read 1368 times)

NateV

  • Zen Apprentice
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
4.2.1.1 DNS Configuration
« on: November 24, 2015, 05:59:16 pm »
Zentyal 4.2.1.1 fresh install and updates. Only change was to attempt to join as an ADC, which failed, I believe due to DNS settings which is why I'm posting here first. I simply want to ping the PDC and am finding it unable to resolve hostnames. DNS module is activated. The web dashboard shows a proper gateway and dns forwarders in place as well as a domain search. What am I missing?

I haven't found a place for a reverse lookup setting like the windows DNS equivalent.
I also haven't done any static routes, as typically this routing should be identified by the default gateway.
I can manually edit the resolv.conf and successfully ping, but I'm guessing I shouldn't have to do that, and this will be overwritten upon reboot, correct?

Any help would be greatly appreciated.

jbahillo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1444
  • Karma: +77/-2
    • View Profile
Re: 4.2.1.1 DNS Configuration
« Reply #1 on: November 24, 2015, 06:25:38 pm »
You should have added the WIndows DC to the Network - DNS list

NateV

  • Zen Apprentice
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: 4.2.1.1 DNS Configuration
« Reply #2 on: November 25, 2015, 03:24:37 pm »
Navigating to the NETWORK > DNS in the webadmin It only shows me a domain search, which I have configured properly as my domain. There is also a note at the top saying that I need to use "Configured Forwarders" with a link to that page.(For the reason that I mentioned in my original post, that DNS module is active and will only use 127.0.0.1 and if that can't find it, it will use forwarders) And yes, I have identified both the PDC and a secondary DC as forwarders. So, it appears that this part is correct, any other suggestions? Thanks for the reply.

NateV

  • Zen Apprentice
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: 4.2.1.1 DNS Configuration
« Reply #3 on: November 30, 2015, 04:47:16 pm »
I disabled all modules except network and logs. I configured interface with a static IP, mask, gateway, and DNS nameservers.
I've noticed that both Gateway and DNS Nameservers configuration in the webadmin, is not showing up in /etc/network/interfaces, shouldn't it be?

Export from /etc/network/interfaces:
auto lo eth0
iface lo inet loopback
iface eth0 inet static
        address 192.168.1.1
        netmask 255.255.255.0
        broadcast 192.168.1.255

Export from /etc/resolv.conf:
search %mydomain.com%

Interestingly, if I manually add my "dns-nameservers 192.168.1.2" to the /etc/network/interfaces, bring the eth0 down, then up, it will tell me that the DNS nameserver already exists. As if it is configured somewhere, like the zentyal webadmin maybe.

I'm just trying to ping said nameserver by using the hostname and it will not resolve the IP address. Pinging by IP address works fine.



Nnik-nbg

  • Zen Apprentice
  • *
  • Posts: 9
  • Karma: +0/-0
  • FanaticsIT
    • View Profile
Re: 4.2.1.1 DNS Configuration
« Reply #4 on: February 19, 2016, 12:47:57 pm »
this seems to be kind of the same issue that I'm currently running in. Did you find an answer for your problem?

jbahillo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1444
  • Karma: +77/-2
    • View Profile
Re: 4.2.1.1 DNS Configuration
« Reply #5 on: February 19, 2016, 04:54:12 pm »
Regarding gateway and DNS's, they are managed by ip route and resolvconf, respectively