Author Topic: Zentyal 4.0 refusing to install on Ubuntu Server 14.04.1  (Read 2434 times)

Auriga

  • Zen Apprentice
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Zentyal 4.0 refusing to install on Ubuntu Server 14.04.1
« on: February 19, 2015, 01:46:01 am »
Hello there.

I've been trying to get Zentyal 4.0 to work on Ubuntu Server 14.04.1, but I've had no luck.

When trying to install Zentyal:

Code: [Select]
majestic12@server:~$ sudo apt-get install zentyal
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 zentyal : Depends: zentyal-core but it is not going to be installed
           Depends: zentyal-software but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Then, I try zentyal-core:

Code: [Select]
majestic12@server:~$ sudo apt-get install zentyal-core
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 zentyal-core : Depends: zentyal-common (>= 4.0.1) but it is not going to be installed
                Depends: zentyal-common (< 4.1) but it is not going to be installed
                Depends: libauthen-simple-pam-perl but it is not installable
                Depends: libcgi-emulate-psgi-perl but it is not installable
                Depends: libclone-fast-perl but it is not installable
                Depends: libfile-mmagic-perl but it is not installable
                Depends: libfilesys-df-perl but it is not installable
                Depends: libjson-rpc-perl but it is not installable
                Depends: liblexical-persistence-perl but it is not installable
                Depends: liblinux-inotify2-perl but it is not installable
                Depends: libnmap-parser-perl but it is not installable
                Depends: libplack-middleware-reverseproxy-perl but it is not installable
                Depends: libplack-middleware-session-perl but it is not installable
                Depends: libproc-processtable-perl but it is not installable
                Depends: libredis-perl (>= 2:1.9670) but it is not installable
                Depends: libstring-shellquote-perl but it is not installable
                Depends: libsys-cpuload-perl but it is not installable
                Depends: libsys-cpu-perl but it is not installable
                Depends: libterm-readline-gnu-perl but it is not installable
                Depends: liburi-encode-perl but it is not installable
                Depends: redis-server (>= 2:2.8.4) but it is not installable
                Depends: uwsgi-plugin-psgi but it is not installable
                Depends: libdate-calc-xs-perl but it is not installable
E: Unable to correct problems, you have held broken packages.

Even deeper, zentyal-common:

Code: [Select]
majestic12@server:~$ sudo apt-get install zentyal-common
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 zentyal-common : Depends: liblog-dispatch-perl but it is not installable
                  Depends: libhtml-mason-perl but it is not installable
                  Depends: libtrycatch-lite-perl but it is not going to be installed
                  Depends: libperl6-junction-perl but it is not installable
                  Depends: libmail-rfc822-address-perl but it is not installable
                  Depends: libsoap-lite-perl but it is not installable
                  Depends: libdata-validate-domain-perl but it is not installable
                  Depends: libio-interface-perl but it is not installable
E: Unable to correct problems, you have held broken packages.

Finally (getting desperate at this point, obviously), zentyal-software:

Code: [Select]
majestic12@server:~$ sudo apt-get install zentyal-software
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 zentyal-software : Depends: zentyal-core (>= 4.0) but it is not going to be installed
                    Depends: zentyal-core (< 4.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

It's a relatively clean installation, the only important packages installed being GitLab and postfix.

Thanks.

Auriga

  • Zen Apprentice
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Zentyal 4.0 refusing to install on Ubuntu Server 14.04.1
« Reply #1 on: February 20, 2015, 05:40:51 pm »
Can anyone help out?

Auriga

  • Zen Apprentice
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Zentyal 4.0 refusing to install on Ubuntu Server 14.04.1
« Reply #2 on: February 21, 2015, 02:02:10 am »
UPDATE: I just tried installing Zentyal 4.0 on a regular Ubuntu 14.04 and it works flawlessly.

wesleymts

  • Zen Apprentice
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: Zentyal 4.0 refusing to install on Ubuntu Server 14.04.1
« Reply #3 on: February 23, 2015, 08:05:19 pm »
Hello like to know how do I install Zentyal on my machine ..