Author Topic: zentyal install f*cked. repair install possible?  (Read 1923 times)

zippydan

  • Zen Monk
  • **
  • Posts: 80
  • Karma: +1/-0
    • View Profile
zentyal install f*cked. repair install possible?
« on: January 31, 2015, 02:41:46 am »
I had a Zentyal 3.5 install that was working relatively well until a power outtage that outlasted our UPS batteries.  Since then, it has been haywire.

Symptoms:

1. When connecting via SSH, I sometimes get a warning that the RSA key has changed and there may be a man-in-the-middle attack.  But after several connect attempts, it will eventually connect without any warning (as if the RSA key has reverted).  I am connecting on the LAN using the LAN IP, so I don't see how there could be a man-in-the-middle attack.

2. Sometimes my users simply can't login to their workstations using their domain credentials.  It says invalid password.  After several attempts, it will finally allow them to login.  Sometimes, restarting samba or restarting Zentyal will fix this problem temporarily.

3. I believe this is related to the same authentication problem: I have an openfire (jabber) server that authenticates using the Zentyal samba.  Usually, their jabber clients are telling them that the login information is incorrect, but after several attempts, it will allow them to login.  Sometimes, restart samba or restarting Zentyal will fix this problem.

4. E-mail simply stops working.  I can still connect to the webmail page for instance, but no emails are received and no emails go out.  (Using openchange)

5. Since updating to Zentyal 4.0, the admin page at port 8443 simply gives me "Internal Server Error"

I tried updating my 3.5 install to Zentyal 4.0, but the problems persist.

I also tried migrating the samba folder to a new Zentyal install, but that doesn't seem to be working very well for me either.

Is there a procedure for doing a repair installation over an existing installation in such a way that the domain/user/email data is retained?
« Last Edit: January 31, 2015, 02:44:12 am by zippydan »

yatscher

  • Zen Apprentice
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: zentyal install f*cked. repair install possible?
« Reply #1 on: April 22, 2017, 06:18:01 pm »
Hi zippydan,

Good day.

I experienced also the power outage, but i have a different symptoms. My zentyal wont boot, it only stuck on a black screen with a lot of horizontal green lines. I have a lot of file that i need to recover. Can you help me with this please? You can see an attached screenshot below.

Thank you.