Author Topic: Samba share is not visible in lan  (Read 8882 times)

cpservicespb

  • Zen Apprentice
  • *
  • Posts: 20
  • Karma: +0/-1
    • View Profile
Re: Samba share is not visible in lan
« Reply #15 on: March 19, 2015, 07:11:49 pm »
As I said there is no necessary to disable AD DS functionality.
There is necessary to 'activate' some parameter at Samba4 and edit start script.
I didn' t check for 4.1 versions, but for 4.0 worked.

puntino80

  • Zen Apprentice
  • *
  • Posts: 23
  • Karma: +0/-0
    • View Profile
Re: Samba share is not visible in lan
« Reply #16 on: March 27, 2015, 10:51:50 am »
As I said there is no necessary to disable AD DS functionality.
There is necessary to 'activate' some parameter at Samba4 and edit start script.
I didn' t check for 4.1 versions, but for 4.0 worked.

Could you tell me what you have done in particular and what is the right procedure?

Cheers

vwdragon

  • Zen Apprentice
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Samba share is not visible in lan
« Reply #17 on: May 25, 2015, 04:27:13 pm »
Hi is there a solution for this problem?

ZAJDAN

  • Zen Apprentice
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Re: Samba share is not visible in lan
« Reply #18 on: May 26, 2015, 01:34:53 pm »
in my case:
when the Samba-computer is on same subnet(192.168.6.1) as client(192.168.6.2), then a client will see in browse network icon of Samba-computer
when the Samba-computer is on another subnet(192.168.1.1) as client(192.168.6.2), then a client will NOT see in browse network icon of Samba-computer and is necessary write \\Samba-computer

PeeZzz

  • Zen Apprentice
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Samba share is not visible in lan
« Reply #19 on: May 31, 2015, 02:38:49 am »
I used to work with MS Windows Servers, but I'm now looking for an alternative for the MS AD and Domain services. Therefore the past couple of days I've been trying out, among others, Zentyal. I have to say that i.m.h.o. Linux is still light years behind. The way services are dealt with is ridiculously  complicated and very limited in possibilities as compared to Windows. I honestly believe they should work on that. At the moment it's a mess with like 4 or 5 different inconsistent ways of handling them :o.

Anyhow, I also had the problem of not being able to browse the Zentyal managed shares. I found out that it was indeed the NMBD service. When I manually start it (/etc/init.d/nmbd restart) the server becomes browsable. However, even though I tried to set the service to auto-start upon booting, that somehow fails. Therefore I've created a workaround:

create a script:
/opt/zentyal/startnmbd.sh

in the script add these lines:
#! /bin/sh
service nmbd start

in /etc/rc.local at the bottom add (before exit 0):
bash /opt/zentyal/startnmbd.sh

That worked for me.

Hope this helps

Edit: btw: It takes a while before the nmbd service will be started with the above method, but eventually it will.
« Last Edit: May 31, 2015, 01:04:17 pm by PeeZzz »

cal

  • Zen Apprentice
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: Samba share is not visible in lan
« Reply #20 on: June 01, 2015, 05:12:40 pm »
I hope it is OK to dig up this old thread, but none of the previous suggestions worked for me.  To solve the problem I added the following to /etc/samba/smb.conf and restarted the service.

Code: [Select]
  #/etc/samba/smb.conf
winbind nss info = rfc2307
  winbind trusted domains only = no
  winbind use default domain = yes
  winbind enum users = yes
  winbind enum groups = yes

Everything seems to work now.  Could someone follow up and let me know if this is going to cause problems somewhere else down the line?

vwdragon

  • Zen Apprentice
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Samba share is not visible in lan
« Reply #21 on: June 14, 2015, 03:22:48 am »
Not working for me :(

PeeZzz

  • Zen Apprentice
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Samba share is not visible in lan
« Reply #22 on: June 18, 2015, 02:01:13 pm »
Sorry, I forgot the sudo in the last bit:

create a script:
/opt/zentyal/startnmbd.sh

in the script add these lines:
Code: [Select]
#! /bin/sh
service nmbd restart

in /etc/rc.local at the bottom add (before exit 0):
Code: [Select]
sudo bash /opt/zentyal/startnmbd.sh
That worked for me.

Hope this helps

Edit: btw: It takes a while before the nmbd service will be started with the above method, but eventually it will.

This REALLY works for me.

grolon

  • Zen Apprentice
  • *
  • Posts: 38
  • Karma: +2/-0
    • View Profile
Re: Samba share is not visible in lan
« Reply #23 on: May 24, 2018, 08:26:36 pm »
Thanks por previous posts

This is what i did

For Zentyal 4.x
# update-rc.d nmbd defaults
# /etc/init.d/nmbd start
# /etc/init.d/nmbd status

For Zentyal 5.x
# systemctl enable nmbd.service
# systemctl start nmbd.service
# systemctl status nmbd.service

Reboot, it works

Regards, Saludos