Author Topic: Problem with grub installing Zentyal 4.0 raid 5  (Read 998 times)

ForzaJappie

  • Guest
Problem with grub installing Zentyal 4.0 raid 5
« on: December 30, 2014, 03:36:28 am »
Hi all,

I have been busy all day trying to install Zentyal with raid 5, however it keeps on failing on the grub install. Afterwards it will not boot.  I have a Gigabyte GA-F2A88XN-WIFI motherboard and 3 Seagate Desktop HDD ST3000DM001, 3TB.

I started with hw raid 5 solution but got some errors because of the size of the partitions. After that I started with a sw raid 5, but got a lot of problems with grub.
I have found this tutorial: http://rafaelwolf.com/?p=919

But it does not seem to help.
Does anyone have a solution maybe?
« Last Edit: December 30, 2014, 03:44:17 am by ForzaJappie »

Daguet57

  • Zen Apprentice
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: Problem with grub installing Zentyal 4.0 raid 5
« Reply #1 on: January 06, 2015, 06:52:38 pm »
Hi.

It seems that SW RAID install on large drive cannot be managed by GRUB 'as is'

I'm also trying to setup a SW RAID fresh install with 2x 3Tb HDD in RAID 1 and i faced this (first) same problem, resolved with the following - on each drive :
a 100Mb partition dedicated to Biosgrub
a 200Mb partition in EXT4, not used, just with boot option
a partition for swap space, used as a RAID partition
a last partition for system (containing approx 3Tb) used as a RAID partition also.

Then, configure both RAID partitions for swap and / partitions, respectively.

Found on internet, this has allowed to pass this GRUB issue, but install is not working yet - i have other issues still open.

Hope this helps.
« Last Edit: January 06, 2015, 08:59:16 pm by Daguet57 »