Author Topic: После обновление zentyal с версии 3.5 на 4.0 перестала работать веб админка  (Read 2758 times)

vitaliy

  • Zen Apprentice
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Здравствуйте, помогите пожалуйста
После обновления Zentyal  с версии 3.5 до версии 4.0, перестала открываться веб админка, как с самого сервера , так и удаленно.Сам сервер работает, все службы тоже, раздает интернет, только пропал доступ к веб админке. обновлял через веб интерфейс, после перезагрузки все и случилось.
вот что показал /var/log/zentyal/error.log

2014/11/12 10:25:10 [error] 14383#0: *127 upstream prematurely closed connection while reading response header from upstream, client: 192.168.0.72, server: , request: "GET /ReleaseUpgrade?action=output HTTP/1.1", upstream: "uwsgi://unix:///run/zentyal-webadmin/webadmin.sock:", host: "192.168.0.1:8443", referrer: "https://192.168.0.1:8443/Dashboard/Index"
2014/11/12 10:25:10 [error] 14383#0: *127 connect() to unix:///run/zentyal-webadmin/webadmin.sock failed (111: Connection refused) while connecting to upstream, client: 127.0.0.1, server: , request: "GET /ReleaseUpgrade?action=output HTTP/1.1", upstream: "uwsgi://unix:///run/zentyal-webadmin/webadmin.sock:", host: "192.168.0.1:8443", referrer: "https://192.168.0.1:8443/Dashboard/Index"
2014/11/12 10:25:10 [error] 14383#0: *127 connect() to unix:///run/zentyal-webadmin/webadmin.sock failed (111: Connection refused) while connecting to upstream, client: 127.0.0.1, server: , request: "GET /ReleaseUpgrade?action=output HTTP/1.1", upstream: "uwsgi://unix:///run/zentyal-webadmin/webadmin.sock:", host: "192.168.0.1:8443", referrer: "https://192.168.0.1:8443/Dashboard/Index"

bubnov-pi

  • Zen Samurai
  • ****
  • Posts: 425
  • Karma: +27/-0
    • View Profile
Порт указываете 8443 (как в 4.0) или не указываете вообще (как в 3.*)?

vitaliy

  • Zen Apprentice
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Если не указывать порт то "Веб-страница недоступна" , если порт 8443 указать то "Internal Server Error"

mad_est

  • Zen Warrior
  • ***
  • Posts: 127
  • Karma: +4/-1
    • View Profile
в англоязычной ветке идет точно такое же обсуждение... проверьте.

vitaliy

  • Zen Apprentice
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
После прочтения https://forum.zentyal.org/index.php/topic,23667.0.html все заработало.Большое спасибо

Chai

  • Zen Apprentice
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Топик больше не существует. Как решать проблему?
А поиском по всему серверу
user@zentyal:~$ sudo find / -name webadmin
user@zentyal:~$ sudo find / -name zentyal
/zentyal
/lib/plymouth/themes/zentyal
user@zentyal:~$


AxetNord

  • Zen Monk
  • **
  • Posts: 78
  • Karma: +1/-0
    • View Profile
Топик больше не существует. Как решать проблему?
А поиском по всему серверу
user@zentyal:~$ sudo find / -name webadmin
user@zentyal:~$ sudo find / -name zentyal
/zentyal
/lib/plymouth/themes/zentyal
user@zentyal:~$
https://forum.zentyal.org/index.php/topic,23815.36.html

пишут попробовать так:
1. Bakcup the file /var/lib/zentyal/conf/webadmin/psgi-subapps.yaml (jsut in case we broke something and had to restore it)
2. Execute: sudo perl -MEBox -MEBox::WebAdmin::PSGI -e'EBox::init(); EBox::WebAdmin::PSGI::removeSubApp("/ebox"); 1'
3. Execute: sudo perl -MEBox -MEBox::WebAdmin::PSGI -e'EBox::init(); EBox::WebAdmin::PSGI::removeSubApp("/soap"); 1'
4. Restart webadmin with "sudo service zentyal webadmin restart"