Author Topic: Smarthost: unknown mail transport error  (Read 2424 times)

Tumos76

  • Zen Apprentice
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Smarthost: unknown mail transport error
« on: October 31, 2014, 12:35:54 am »
Hallo Community,
ich habe heute einen Zentyal 4.0 aufgesetzt und mache gerade meine ersten Schritte mit OpenChange. Da ich meine Mails über einen Server im öffentlichen Internet versende, habe ich wie auch beim 3.x die jeweiligen Smarthost-Daten eingetragen. Leider kann ich aber keine Mails versenden, im Log finde ich folgendes:
Quote
unknown mail transport error
bzw.
Quote
Oct 31 00:27:38 xxxxx postfix/master[5110]: warning: process /usr/lib/postfix/smtp pid 6680 exit status 1
Oct 31 00:27:38 xxxxx postfix/qmgr[5113]: warning: transport smtp failure -- see a previous warning/fatal/panic logfile record for the problem description
Oct 31 00:27:38 xxxxx postfix/error[6682]: D5A9A201352: to=<xxxxxxx@hotmail.com>, relay=none, delay=2161, delays=2160/1.2/0/0, dsn=4.3.0, status=deferred (unknown mail transport error)

Ich wäre für jede Hilfe dankbar?

Nachtrag: Auch ohne Smarthosteintrag erscheint die gleiche Fehlermeldung. Habe auch noch folgendes gefunden:
Quote
warning: hash:/etc/postfix/generic lookup error for "xxxxxxxxxx@xxxxxxxxxx"[7;6H1 00:40:09fix/smtp[7528]: fatal: smtp_generic_maps map lookup problem for xxxxxxxxxx@xxxxxxxxxx1 00:40:10fix/qmgr[5113]: warning: private/smtp socket: malformed response1 00:40:10fix/qmgr[5113]: warning: transport smtp failure -- see a previous warning/fatal/panic logfile record for the problem description1 00:40:10fix/master[5110]: warning: process /usr/lib/postfix/smtp pid 7528 exit status 11 00:40:10postfix/master[5110]: warning: /usr/lib/postfix/smtp: bad command startup -- throttling1 00:40:10error[7529]: 3AD882015F8: to=<xxxxxxxxxx@hotmail.com>, relay=none, delay=1.3, delays=0.1/1.2/0/0.01, dsn=4.3.0, status=deferred (unknown mail transport error)1 00:42:36qmgr[5113]: AB34C201364: from=<xxxxxxxxxx@xxxxxxxxxx>, size=2404, nrcpt=1 (queue active)1 00:42:36postfix/smtp[7606]: error: open database /etc/postfix/generic.db: No such file or directory

Viele Grüße
Tumos

« Last Edit: October 31, 2014, 12:53:30 am by Tumos76 »

chrischnian

  • Zen Monk
  • **
  • Posts: 53
  • Karma: +0/-0
    • View Profile
Re: Smarthost: unknown mail transport error
« Reply #1 on: October 31, 2014, 09:25:22 pm »
jo hier auch nach einen Update!

mp

  • Zen Apprentice
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Smarthost: unknown mail transport error
« Reply #2 on: November 01, 2014, 05:26:24 pm »
hallo zusammen,

handelt sich scheinbar um nen bug,

https://github.com/Zentyal/zentyal/commit/9b241e9cddad647b09aadf19b5062008f00be2f3

/usr/share/zentyal/stubs/mail/main.cf.mas

# % if ($openchangeProvisioned) {
# smtp_generic_maps = hash:/etc/postfix/generic
# % }

die drei zeilen auskommentieren, dann hat es zumindest bei mir funktioniert.

funktioniert bei euch eigentlich bei outlook 2010 der abwesenheitsassistent?

grüße
martin


franzl1006

  • Zen Apprentice
  • *
  • Posts: 15
  • Karma: +1/-0
    • View Profile
Re: Smarthost: unknown mail transport error
« Reply #3 on: November 02, 2014, 11:44:30 am »
Hallo,

GENAU DAS WAR ES!!!!!!
Genau den selben Fehler hatte ich bei meiner Installation. Mails innerhalb der Domäne wurden gesendet, von außerhalb empfangen, aber keine Mails nach außen verschickt. Jetzt funktioniert alles, nach unendlichen Versuchen. Vielen Dank und Lob an den Entdecker!!!

Der Abwesenheits-Assistent und die Kalenderfunktion klappt bei mir auch. Das hat mit der autodiscover-Funktion zu tun, die nur dann funktioniert, wenn nur EINE virtuelle Mail-Domäne angelegt ist. Diese sollte von vornherein die richtige Adresse haben. Also "xyz.de" oder "abc.com", etc. Legt man zum Beispiel "zentyal-domain.lan" an und danach "xyz.de", klappt bei Outlook-Exchange auf dem Windows-PC das autodiscover nicht oder nicht mehr! Zumindest war es bei mir so. Ich habe Wochen getestet und probiert - ohne Erfolg, bis ich drauf kam.

PS: Dieses auskommentieren der drei Zeilen wird wahrscheinlich nach einem Update nicht mehr vorhanden sein. Ich habe mir die Datei deshalb extra mit einem neuen Namen gesichert. Was ich aber nicht verstehe, ist die Tatsache, dass solche "Bugs" nach einem Release, bei einem vernünftigen vorherigem Test durch die Entwickler, nicht vorkommen dürften!

Nochmals Danke und Viele Grüße
Frank

mp

  • Zen Apprentice
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Smarthost: unknown mail transport error
« Reply #4 on: November 04, 2014, 01:10:35 pm »
hallo frank,

gleicher gedanke, wie kann bei einem major-release so eine grundlegende funktion fehlerhaft sein?
autodiscover funktionierte bei mir nach anlegen des eintrags im DNS, war dieser bei dir schon automatisch angelegt?

bei mir hatte auch der abwesenheitsassistent nicht funktioniert, genau wie zugriff auf andere kalender bzw gebucht-zeiten.
thema virtuelle domäne werde ich mir nochmals ansehen, bin mir gerade nicht sicher ob die interne noch existiert, vielleicht ist dies des rätsel's lösung.

vielen dank für den hinweis

grüße
martin



franzl1006

  • Zen Apprentice
  • *
  • Posts: 15
  • Karma: +1/-0
    • View Profile
Re: Smarthost: unknown mail transport error
« Reply #5 on: November 04, 2014, 04:26:19 pm »
Hallo Martin,

der DNS-Eintrag.. Meinst du den unter Netzwerk oder direkt unter DNS? Also, der erste wird automatisch angelegt, wenn der Server installiert und ein Name vergeben wird. Aber das ist genau der Punkt: wird der Server zum Beispiel "zentyal-domain.lan" oder "schulze.local" genannt, reagiert autodiscover später nur auf diesen Namen.

Das heißt, die virtuelle Mail-Domain ist somit die Mailendung bei ausgehenden Mails. Z. Bsp. user@zentyal-domain.lan oder schulze@schulze.lan.
Damit funktioniert autodiscover in Outlook, was das anlegen eines Mailkontos betrifft. Nur damit ist dir bei Mails an externe Adressen ausserhalb deiner Domäne nicht geholfen. Die Mails gehen nämlich nicht raus, nur intern funktioniert das verschicken.
Man kann später natürlich noch eine weitere virtuelle Mail-Domain anlegen, wie etwa "abc.de" , aber das macht dann autodiscover nicht mit. Die Mails gehen zwar durchaus auch extern raus, wenn man auf der Weboberfläche bei  "Userkonfiguration/Neues E-Mail Alias" die Endung abc.de auswählt. Dann steht die Mail-Endung meier@abc.de hinten dran. Meldet man sich aber am Meier-Konto auf dem PC an - öffnet Outlook und wählt "Konto automatisch anlegen", klappt das garantiert nicht!!!
Die Konto-Konfiguration lässt sich nur noch manuell einstellen. Mit dem Erfolg, dass Mails zwar alle rausgehen, aber der Kalender nicht freigegeben werden kann und die "Out-of-Office-Funktion" lässt sich nicht aufrufen.

Deshalb ist es im Sinne von Outlook und autodiscover WICHTIG, die Domäne bei der Installation sofort so zu benennen, wie später die Mailadresse aussehen soll.
Also etwa: hostname.abc.de oder anders: schulzeserver.schulze.com. Die Mailadresse wäre dann im letzteren Fall zum Beispiel: welcher_name_auch_immer@schulze.com.

Ich hoffe, ich habe helfen können?

Gruß Frank