Author Topic: outgoing mail to external domain  (Read 1236 times)

JayJay

  • Zen Apprentice
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
outgoing mail to external domain
« on: September 19, 2014, 10:03:34 pm »
hi !

I want to configure zentyal 3.4 to send mail to mail accounts in any domain .
I managed to fix this using the smarthost option in the mail server configuration in zentyal.

But this config results in  the fact that the sender of mails (at the receiving end) is the smarthost authentication account configured .(see attachment)
Where I would like to have the zentyal account, let's say user@mydns.com ,as the originator of the outgoing email.


Is that possibel? And how?

« Last Edit: September 19, 2014, 10:06:40 pm by JayJay »

Syntax

  • Zen Apprentice
  • *
  • Posts: 22
  • Karma: +1/-0
    • View Profile
Re: outgoing mail to external domain
« Reply #1 on: September 20, 2014, 01:49:32 am »
I'm not sure I understand.  You want Zentyal mail users to be able to email anyone, not just people in their own domain, correct?

If that is what you are trying to accomplish, then there is nothing you need to do except allow Zentyal to send mail through your firewall, and have the server's DNS set up properly.  Oh, and have email enabled.

JayJay

  • Zen Apprentice
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: outgoing mail to external domain
« Reply #2 on: September 20, 2014, 07:53:02 am »
The reason the users in my domain could not send mail to other domains, was because my Internet Srervice Provider (ISP) blocks outgoing port 25 (from my perspective) to all destinations except theirs.

This is done in order to prevent spam mail being sent;
in this construction all spam - if any-  has to be routed along their mail router.

To accomplish sending mail  with this restriction and compatible with zentyal setup,  the ISP (smtp.isp.com) is configured without authentication, as the screenshot shows...
Result is that any user in any domain receiving mail from my domain , reads my domain user as the sender, not the smarthost authentication account as pointed out in  my first post.


« Last Edit: September 20, 2014, 08:22:34 am by JayJay »