Author Topic: [Solved] how to setup a virtual interface on eth0 (standalone server)  (Read 1904 times)

zippydan

  • Zen Monk
  • **
  • Posts: 80
  • Karma: +1/-0
    • View Profile
I see under Network -> Interfaces, I have the option to create a Virtual Interface on my LAN port.  This should be simple but what keeps throwing me is the "Name" field and there is no guidance either in the webadmin or in the online documentation, except for the errors I get.

I tried putting a descriptive name like: "Secondary.Connection" and Zentyal said NO: Invalid value for Virtual interface name

I tried putting a linux name like "eth0:1" and Zentyal said NO: Invalid value for Virtual interface name

I tried putting a useless name like "abcd" and finally Zentyal said YES.

"1" also worked.

Is this correct?
« Last Edit: September 22, 2014, 08:43:04 pm by zippydan »

Escorpiom

  • Zen Hero
  • *****
  • Posts: 897
  • Karma: +25/-1
    • View Profile
Re: how to setup a virtual interface on eth0 (standalone server)
« Reply #1 on: September 16, 2014, 09:57:26 pm »
Yes, that is correct.
Zentyal always had trouble with spaces, periods, hyphens, colon and semicolon.
Look at my sig.

Cheers.
Marcus' Rule:
Blanks & capitals = avoid it and you'll avoid problems...

Syntax

  • Zen Apprentice
  • *
  • Posts: 22
  • Karma: +1/-0
    • View Profile
Re: how to setup a virtual interface on eth0 (standalone server)
« Reply #2 on: September 20, 2014, 01:58:07 am »
Escorpiom:

+1 on that sig.  Had to do a full reinstall of a server that was live (fortunately it was virt. and could do it as a separate instance and after hours) and populated with... more than a few users... because DomainName.ext is not the same as domainname.ext

That hurt.