Author Topic: [SOLVED]Unable to set Out of Office in Outlook 2010 and SOGo  (Read 3225 times)

stevew

  • Zen Apprentice
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
I have installed a few test servers of Zentyal 3.5 and accidentally upgraded another server to 3.5 in the hope the PST importing had been fixed (all signs point to yes!).

However, I have had issues setting an Out of Office reply for all users on Outlook 2010 (it's what most of my clients use) and I also cannot set the Vacation response in SOGo.

I read on the upgrade page to 3.5 that usernames with a capital letter cannot set an out of office, but I have been extremely careful not to do this, and I still cannot get a successful out of office message.

I've attached screenshots of the issue to this post. I have no idea which logs might contain my errors, so if anyone could give me a hint, I'll be more than happy to provide these too.

Thanks

« Last Edit: August 05, 2014, 11:21:25 am by stevew »

stevew

  • Zen Apprentice
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
Re: Unable to set Out of Office in Outlook 2010 and SOGo
« Reply #1 on: July 30, 2014, 11:35:16 am »
So I've done some more digging, Googling and testing ...

I cannot find the OpenChange log, or it's not obvious. But I extracted these from ocsmanager.log

2014-07-30 12:19:16,321 ERROR [ocsmanager.lib.config] [MainThread] /etc/ocsmanager/ocsmanager.ini: Missing [autodiscover:rpcproxy] section
Removing PID file /var/run/ocsmanager/ocsmanager.pid

From SOGo, every time I try to set the Out of Office, I get the following:
Jul 30 11:49:37 sogod [5257]: [ERROR] <0x0x7f5c444117a8[NGLdapAttribute]> could not convert value of objectSid to string
Jul 30 11:49:37 sogod [5257]: [ERROR] <0x0x7f5c44411208[NGLdapAttribute]> could not convert value of objectGUID to string

It's the best I've been able to find thus far, I've spent days trawling through the logs looking for errors.

stevew

  • Zen Apprentice
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
Re: Unable to set Out of Office in Outlook 2010 and SOGo
« Reply #2 on: July 30, 2014, 11:59:11 am »
I've now managed to figure out the SOGo issue, which requires me to set the setting "Manage Sieve Scripts" under the general mail options on the dash.

I still don't have Outlook handling Out of Office replies, but I'll continue to work on it and report back.

One think I have noticed though, is that I cannot get rid of the certificate warning, even if the machine is connected to the domain. I am always getting the error that the certificate name is invalid or doesn't match the name of the site. I am wondering if this is messing with Outlook and connecting to the Out of Office service.

stevew

  • Zen Apprentice
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
Re: Unable to set Out of Office in Outlook 2010 and SOGo
« Reply #3 on: August 05, 2014, 11:20:23 am »
OK, It seems I have now figured all of this out. So here goes ...

First of all, download the following using wget:

Code: [Select]
wget http://archive.zentyal.org/zentyal/pool/main/z/zentyal-openchange/zentyal-openchange_3.5.3_all.deb
Install the .deb file

Code: [Select]
sudo dpkg -i zentyal-openchange_3.5.3_all.deb
Reboot your server

From there, I had to do the following:

Code: [Select]
sudo cp /etc/apache2/conf.d/ocsmanager.conf /etc/apache2/conf-available/
Code: [Select]
sudo a2enconf ocsmanager
Code: [Select]
sudo service apache2 restart
I was then able to set Out of Office replies and use Autodiscover using Outlook 2007 and Outlook 2010.

I'd like to point out that my solution came from reading the following document:
http://www.sogo.nu/files/docs/SOGo%20Native%20Microsoft%20Outlook%20Configuration.pdf
« Last Edit: August 05, 2014, 11:22:41 am by stevew »