Author Topic: 3.5 como BDC problemas com Grupos e Proxy  (Read 1041 times)

celangoni

  • Zen Apprentice
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
3.5 como BDC problemas com Grupos e Proxy
« on: July 26, 2014, 11:50:38 pm »
Olá,

Estou fazendo uns testes com o Zentyal 3.5 e encontrei alguns problemas na integração com o Active Directory e gostaria da ajuda de vocês para melhor identificar o problema e se for o caso abrir um Bug Request.
Vou tentar ser o mais descritivo possível, então me desculpem se ficar um pouco extenso demais.

Do lado Windows tenho um windows 2008R2 SP1 64bits, sem nenhuma atualização adicional (A media já é 2008 R2 SP1)
O sistema foi instalado com as opções padrões e o firewall foi devidamente desativado (o serviço como um todo).
Na configuração do AD o nível funcional tanto da floresta quanto do domínio está 2003. O IP é 10.0.0.2.
O domínio é lab.local o nome da máquina WINAD.
Além disso eu criei na raiz do diretório uma OU chamada LAB e dentro dela duas OUs Usuarios e Grupos.
Criei os grupos full, blacklist e whitelist, e o usuário kadu, como parte do grupo full; dentro das OUs citadas acima.

Do lado Zentyal tenho um Zentyal 3.5 64bits, totalmente atualizado. Possui o IP 10.0.0.1.
Tem instalado os módulos Firewall, Proxy HTTP, Usuários, Grupos e Comparilhamento de arquivos, DNS e os outros módulos dependentes destes.
Eu habilitei todos os módulos, configurei a rede; liberei ssh e zentyal webadmin no firewall para redes externas;  fiz o processo normal para adicionar o zentyal como um controlador de domínio adicional, tudo transcorreu sem erros na interface web.
Como meu objetivo inicial era um proxy http com single sign on comecei a notar os problemas a partir daqui.

Quando fui adicionar uma regra de acesso para os grupos do AD percebi que os únicos grupos que aparecem são:
All domain users
Domain Admins
Domain Guests
Domain Users

Nenhum dos grupos do OU Grupos criados por mim aparece na lista de Grupos de Usuários para origem da regra de acesso.

Ao verificar no gerenciador de usuários e grupos notei mais duas situações.
Nos grupos que estão dentro da OU grupos criado por mim eu não vejo usuários, ele diz que não tem usuário no grupo (This group does not have members), mas o usuário kadu está no grupo full, e vejo isso nas propriedades do usuário.
Notei ainda que se eu clicar no menu drop down Usuários que tem nas propriedades dos grupos apenas os usuários Administrator e Guest aparecem, não sendo possível adicionar usuários ao grupo por esta tela.
Mas nas propriedades dos usuários aparecem todos os grupos normalmente, inclusive sincronizando com o AD quando no zentyal eu adicionei um grupo para o usuário.

Criei um grupo int-full na OU padrão Users e o grupo apareceu perfeitamente no zentyal, mas com o mesmo comportamento só aparecem os usuários Administrator e Guest, e nas propriedades do usuário aparecem os grupos perfeitamente.

O grupo que criei na OU padrão Users também não apareceu no drop down Grupos de Usuários no Proxy HTTP.

Nas buscas que realizei através de erros no /var/log/samba/samba.log encontrei um problema com o SYSVOL, e os comandos samba-tools ntacl sysvolcheck e sysvolrestore apresentam um erro.
Não sei se está relacionado ao problema acima ou se é algum outro problema. Só consegui executar um sysvolcheck com sucesso após executar um sysvolrestore --use-ntvfs.
De qualquer forma nada disso mudou o cenário do problema com os grupos.

Aqui http://paste.ubuntu.com/7869138/ tem o zentyal.log completo deste servidor
Aqui http://paste.ubuntu.com/7869141/ tem o samba.log também completo.

Se eu puder fornecer mais alguma informação não exitem em perguntar, no que eu puder colaborar para melhorar o zentyal estou as ordens!

Abraços!
Kadu

UPDATE:
Fiz um outro teste em um Zentyal, também 3.5, que tenho em produção aqui, mas que é controlador primário e não tem nada de windows no cenário.
Neste servidor funciona tudo perfeitamente, os grupos mostram os usuários que fazem parte dele, os usuários aparecem nos drop down perfeitamente.
:)
« Last Edit: July 27, 2014, 12:06:12 am by celangoni »