Author Topic: zentyal,postfix und port 465 (ssmtp)  (Read 1528 times)

weißnix

  • Zen Monk
  • **
  • Posts: 76
  • Karma: +1/-0
    • View Profile
zentyal,postfix und port 465 (ssmtp)
« on: July 06, 2014, 10:31:07 pm »
Ich mach mal zum Thema einen neuen Fred auf:


Quote
Falls noch jmd. das Thema interessiert:

Durch einen Mailproviderwechsel stand ich auch plötzlich vor dem Port 465 problem.

Nach einer schlaflosen Nacht folgendes Ergebnis:
-Postfix scheint den Clientmodus auf Port 465 nicht einwandfrei zu unterstützen
-stunnel ist ein kleiner Dämon, der hier hilft.

Also kleines Kurz-Tutorial:

via apt stunnel4 installieren
-funzte tadellos, Pfade,Rechte usw. scheinen ok

/usr/share/doc/stunnel4/examples/stunnel.conf-sample kopieren nach etc/stunnel
Basisbeispiel:
Code: [Select]
client = yes
[ssmtp]
accept = localhost:11025
connect = deinmailserver.domain:465

am Ende einfügen und die nicht benötigten Examples löschen.

in der datei /etc/default/stunnel4
Code: [Select]
enabled=1
setzen.

stunnel neustarten

Jetzt in Zentyal:
Als Smarthost wird localhost:11025 eingetragen
Als Passwort natürlich das des Mailproviders.

Hat soweit auf anhieb gefunzt. Da der Loglevel default auf 7 steht, wurde ich mit ausführlichen Logs belohnt, die den Erfolg der Aktion bestätigen.
So, lange genug geschrieben, meine Testmail ist angekommen und alles ist gut. Damit war der Umzug zum neuen Mailprovider kein Reinfall.

Soweit so prima. Aber
Böse Falle Reboot. Nach einem solchen startet die Kiste nicht komplett durch. Irgendwie startet Zentyal und webmin nicht. Ich habe schon alle Möglichen und unmöglichen Sachen (aus sicht des blutigen Laienadmins) probiert.
Irgendwie steh ich auf dem schlauch.
Starte ich stunnel manuell, funzt es tadellos. Starte ich die Kiste neu, scheint sich irgendwas im Bootvorgang zu verhaken.
« Last Edit: July 06, 2014, 10:34:40 pm by weißnix »
Zentyal 7 auf Atom D525; 4GB RAM, 240 GB SSD,

File- und Mailserver
Remotezugriff via VPN

weißnix

  • Zen Monk
  • **
  • Posts: 76
  • Karma: +1/-0
    • View Profile
Re: zentyal,postfix und port 465 (ssmtp)
« Reply #1 on: September 21, 2014, 05:34:40 pm »
Nachdem ich in Abständen mal dies und mal jenes Versucht habe, stunnel automatisch beim Systemstart mitzuladen bin ich jetzt entnervt folgenden Weg gegangen:

stunnel hab ich den automatischen Start verboten. Dann hab ich einen Cron-Job erstellt, der stunnel alle 15min versucht zu starten. Wenn stunnel schon läuft ist alles ok.
Damit habe ich gewährleistet, das stunnel während eines reboots nicht alles durcheinanderbringt (wasauchimmerverdammtesch...).

Wenn ich das nächste mal (lust) und Zeit dazu habe, kann ich den Startbefehl ja mal versuchsweise an irgendwas anhängen, was von Zentyal gestartet wird.

Aber warum startet mein System nicht, wenn stunnel mitstartet? Is mir voll das Rätsel.!
Zentyal 7 auf Atom D525; 4GB RAM, 240 GB SSD,

File- und Mailserver
Remotezugriff via VPN