Author Topic: Atualização zentyal-ips  (Read 1175 times)

PsInformatica

  • Zen Apprentice
  • *
  • Posts: 26
  • Karma: +0/-1
    • View Profile
Atualização zentyal-ips
« on: July 01, 2014, 04:26:33 pm »
Opa galera beleza , estou com o seguinte problema  eu atualizei o componente suricata depois disso fui atualizar o sistema novamente ele me retorna isso zentyal-ips   Zentyal - Intrusion Prevention System   3.4 
Erro :
Para resolver esta situação, tente executar o seguinte comando na console:

sudo dpkg --configure -a

ai eu executo o comando e aparece isso :

root@firewallvellar:~# sudo dpkg --configure -a
Configurando suricata (1.4.3-1ubuntu1) ...
 * NFQUEUE support not found !
 * Please ensure the nfnetlink_queue module is loaded or built in kernel
invoke-rc.d: initscript suricata, action "start" failed.
dpkg: erro ao processar suricata (--configure):
 sub-processo script post-installation instalado retornou estado de saída de erro 5
dpkg: problemas com dependências impedem a configuração de zentyal-ips:
 zentyal-ips depende de suricata; porém:
  Pacote suricata não está configurado ainda.

dpkg: erro ao processar zentyal-ips (--configure):
 problemas de dependência - deixando desconfigurado
Erros foram encontrados durante o processamento de:
 suricata
 zentyal-ips

me ajudem , eu uso a versão 3.4.7 em produção .



thiagotgc

  • Zen Warrior
  • ***
  • Posts: 127
  • Karma: +1/-0
    • View Profile
Re: Atualização zentyal-ips
« Reply #1 on: August 22, 2014, 03:38:59 pm »
Code: [Select]
sudo apt-get remove suricata
Code: [Select]
sudo apt-get purge suricataThis following command move all packages files that contains suricata to /tmp folder:
Code: [Select]
sudo mv /var/lib/dpkg/info/suricata.* /tmp/and this command force to remove the package:
Code: [Select]
sudo dpkg --remove --force-remove-reinstreq suricataafter do
Code: [Select]
sudo apt-get cleanand
Code: [Select]
sudo apt-get updateand now suricata is remove, but i still don't know how to reinstall zentyal-ips after the upgrade from 3.3 to 3.4. Without the problem list above.
Code: [Select]
invoke-rc.d: initscript suricata, action "stop" failed.
dpkg: warning: subprocess old pre-removal script returned error exit status 5
dpkg: trying script from the new package instead ...
 * NFQUEUE support not found !
 * Please ensure the nfnetlink_queue module is loaded or built in kernel
invoke-rc.d: initscript suricata, action "stop" failed.
dpkg: error processing /var/cache/apt/archives/suricata_1.4.3-1_amd64.deb (--unpack):
 subprocess new pre-removal script returned error exit status 5
 * NFQUEUE support not found !
 * Please ensure the nfnetlink_queue module is loaded or built in kernel
invoke-rc.d: initscript suricata, action "start" failed.
dpkg: error while cleaning up:
 subprocess installed post-installation script returned error exit status 5
Errors were encountered while processing:
 /var/cache/apt/archives/suricata_1.4.3-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
--------------BRASIL---------------