Author Topic: Using Apache and .htaccess with ebox web server  (Read 2679 times)

MrSplash

  • Zen Apprentice
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Using Apache and .htaccess with ebox web server
« on: October 28, 2009, 06:21:51 pm »
Hi,

I'm running ebox for our office filesharing and also have the ebox web server installed. However I can't seem to get .htaccess files to work.

I have created a .htaccess file and inserted some gobbledygook which should give me an internal server error, however it isn't happening. How to I turn on the usage of .htaccess files?

Thanks

sixstone

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1417
  • Karma: +26/-0
    • View Profile
    • Sixstone's blog
Re: Using Apache and .htaccess with ebox web server
« Reply #1 on: November 03, 2009, 10:09:50 am »
You may have to added manually to your virtual hosts. Check the official apache documentation [1] for this.

Cheers,

[1] http://httpd.apache.org/docs/2.0/howto/htaccess.html
My secret is my silence...

MrSplash

  • Zen Apprentice
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Using Apache and .htaccess with ebox web server
« Reply #2 on: November 13, 2009, 06:59:01 pm »
i've tried this and it doesn't work. My virtual host config file looks like this:

Code: [Select]
NameVirtualHost *

<VirtualHost *>
        ServerAdmin webmaster@localhost

        ServerName primeFocus
        DocumentRoot /var/www/site

        ErrorLog /var/log/apache2/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog /var/log/apache2/access.log combined
        ServerSignature On

        # Under this directory you can manually configure every thing
        # you may need of that stuff
        Include sites-available/user-ebox-site/*

        AccessFileName .htaccess


        Options Indexes FollowSymLinks
</VirtualHost>
<Directory />
AllowOverride None
</Directory>

Could you shed some light on where we are going wrong.

We have mod_rewrite loaded.