Author Topic: Need to downgrade Zentyal to 3.3.5  (Read 2070 times)

Aeoran

  • Zen Apprentice
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Need to downgrade Zentyal to 3.3.5
« on: March 31, 2014, 06:31:20 pm »
It looks like this morning's upgrade to Zentyal 3.3.7 utterly breaks my installation.  I need to downgrade to 3.3.5, but the repositories have been scrubbed clean, and I cannot find this version anywhere.

Can anyone please assist?

All I need is to downgrade zentyal-core.

Aeoran

  • Zen Apprentice
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: Need to downgrade Zentyal to 3.3.5
« Reply #1 on: April 01, 2014, 08:52:23 am »
I was able to get things re-running not by downgrading, but by manually restarting each zarafa service in /etc/init.d.

Upgrading to zentyal-core 3.3.7 from 3.3.5 introduced a fatal exception in Zarafa - the object method enableInnoDBIfNeeded is now missing.

I'm highly concerned that this class of bugs would exist in releases of software supposedly destined for enterprise use.

My /var/log is filled with hundreds of megabytes of Zentyal exceptions all the time.  Surely there could be better bench testing for Zentyal.

The problems in Zentyal are non-trivial.  In the past three months, going to 3.x has caused the following utterly weird and fatal problems: database corruption, user mailboxes randomly unlinked and deleted, core dumps due to integration of non-functional versions of third-party components, dovecot integration with zarafa dying mysteriously once per week and requiring a system reboot once per week, zentyal keeling over when imap sync is stressed...

I have been using Zentyal for the past few months to test its worthiness as an enterprise mail/groupware server.  The problems I've seen make this solution seem quite immature; I like what the company is trying to achieve, but at this time, I couldn't possibly recommend this solution to anyone that needs to count on their email.

half_life

  • Bug Hunter
  • Zen Hero
  • *****
  • Posts: 866
  • Karma: +59/-0
    • View Profile
Re: Need to downgrade Zentyal to 3.3.5
« Reply #2 on: April 01, 2014, 05:47:32 pm »
They know that they broke Zentyal with the last push in the 3.3 series.  They have no intention of fixing it since it isn't an LTS version or the current version.  I am in the same boat as you.  I will probably spin up a 3.4 instance this weekend and test transferring everything over.  This is the way I normally do this now vs use the upgrade tool.  I have been a user since 2.0 and have supported this in a corporate environment.  My advice would be the same for this as it would be for MS or any other vendors code used in mission critical apps.  Test it.  Test it some more.  Then backup and validate your backup set before proceeding with an upgrade.

Just my two cents.

Aeoran

  • Zen Apprentice
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: Need to downgrade Zentyal to 3.3.5
« Reply #3 on: May 04, 2014, 05:41:27 pm »
That's a wise idea.

I've been testing the use of the community edition to see if the full version would be suitable as an enterprise solution.

Coupled with Zentyal's continued lack of responses to my questions on this front, and the way that Zentyal goes about architecting and fixing bugs, I suspect that Zentyal is too much of an integrator and not enough of a technology company to truly support the market they want - companies who are looking for rock-solid and dependable solutions, who need to spend all of their cycles building their own businesses instead of helping Zentyal debug theirs.