Author Topic: [RESOLVIDO] Erro após Atualização para 3.4  (Read 1573 times)

albnunes

  • Zen Apprentice
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
[RESOLVIDO] Erro após Atualização para 3.4
« on: April 19, 2014, 05:00:35 pm »
 :-[ Apos atualização para a Versão 3.4 não consigo acessar parte administração nem localmente nem remotamente.
Erro:
503 Service Unavailable

No server is available to handle this request.

Preciso de ajuda.
Existe alguma forma de voltar a versão.
« Last Edit: May 01, 2014, 03:39:24 pm by albnunes »

Tiago

  • Zen Warrior
  • ***
  • Posts: 122
  • Karma: +11/-1
    • View Profile
Re: Erro após Atualização para 3.4
« Reply #1 on: April 19, 2014, 08:54:11 pm »
Cara meu medo era esse e por isso não atualizei, pois antes de fazer a atualização olhei a documentação e la dizia o seguinte:

Mudanças Essenciais

Nova distribuição base: Ubuntu 13.10 picante
A remoção da instância do Apache para a Administração Zentyal
Melhoria do sistema de relatórios de erros
Melhor gerenciamento de exceções

https://wiki.zentyal.org/wiki/Zentyal_3.4_Announcement

Essa remoção não deixa acessar pela web. Agora se você não fez backup não sei se existe outra maneira de retornar a versão.
« Last Edit: April 20, 2014, 12:26:02 am by Tiago »

albnunes

  • Zen Apprentice
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: Erro após Atualização para 3.4
« Reply #2 on: April 20, 2014, 01:34:03 am »
Tiago, Obrigado pelas informações.
Nossa nem me fale, tenho de achar o backup, pq se eu não conseguir acessar remotamente estou ferrado.
E o pior eu deixei o técnico local para fazer as atualizações e ele selecionou achando que podia ser feito.
Tem alguma forma de recuperar e voltar na versão anterior.

Tiago

  • Zen Warrior
  • ***
  • Posts: 122
  • Karma: +11/-1
    • View Profile
Re: Erro após Atualização para 3.4
« Reply #3 on: April 25, 2014, 10:19:49 pm »
Cara você não consegue acessar nem fisicamente? Porque fiz um teste como maquina virtual e essa atualização permitiu o acesso direto na maquina, agora vou testar via web se funciona e te respondo.

albnunes

  • Zen Apprentice
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: Erro após Atualização para 3.4
« Reply #4 on: April 28, 2014, 04:12:46 pm »
Nem localmente no servidor.
E ate agora não sei o que esta ocorrendo.

karlosgyn

  • Zen Apprentice
  • *
  • Posts: 26
  • Karma: +0/-0
    • View Profile
Re: Erro após Atualização para 3.4
« Reply #5 on: April 30, 2014, 10:07:13 pm »
Pessoal, segue a correção para o bug.
Acesso o servidor via ssh: (Obs. caso tenha dificuldade de acessar remotamente execute pela console do servidor)

sudo echo "del webadmin/ro/nginxIncludes" | /usr/share/zentyal/redis-cli
sudo service zentyal webadmin restart

Resolveu em todos meus clientes.
Abs

Raphael Mohandas

  • Zen Apprentice
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Re: Erro após Atualização para 3.4
« Reply #6 on: April 30, 2014, 10:22:03 pm »
Karlos valeu pela ajuda a interface do webadmin voltou a funcionar traquilo valeu.

albnunes

  • Zen Apprentice
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: Erro após Atualização para 3.4
« Reply #7 on: May 01, 2014, 03:35:12 pm »
Valeu Karlos, esta tudo normalizado aqui tb.
Albérico.

Tiago

  • Zen Warrior
  • ***
  • Posts: 122
  • Karma: +11/-1
    • View Profile
Re: [RESOLVIDO] Erro após Atualização para 3.4
« Reply #8 on: May 02, 2014, 05:16:15 am »
Você conseguiu acessar via web também ou apenas localmente?

karlosgyn

  • Zen Apprentice
  • *
  • Posts: 26
  • Karma: +0/-0
    • View Profile
Re: [RESOLVIDO] Erro após Atualização para 3.4
« Reply #9 on: May 02, 2014, 02:24:02 pm »
Tiago, se funcionar localmente e você não tiver alterado a configuração do firewall, tem que funcionar via Web também. O Seu problema persiste?

albnunes

  • Zen Apprentice
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: [RESOLVIDO] Erro após Atualização para 3.4
« Reply #10 on: May 02, 2014, 05:27:14 pm »
Funcionou localmente e via web.
Verifica o redirecionamento do modem DMZ.