Author Topic: !!! aidez-moi svpm !!! plantage pendant maj en 3.4  (Read 893 times)

djnenex

  • Zen Apprentice
  • *
  • Posts: 14
  • Karma: +0/-0
    • View Profile
!!! aidez-moi svpm !!! plantage pendant maj en 3.4
« on: April 13, 2014, 05:51:43 pm »
bonjour, j'ai un tres tres gros probleme, mon serveur est planté suite a la maj en 3.4
le serveur a bien rebooté mais impossible d'avoir accés au reseau depuis les postes clients, impossible également d'accéder a l'interface de gestion web du serveur (aussi bien depuis un poste client que depuis le serveur lui-meme).

un apt-get update / apt-get upgrade me retourne des erreurs, il y a des problemes de dependances non satisfaites:

apache2-mpm-prefork : Dépend: apache2 (= 2.4.6-2ubuntu2.2) mais il n'est pas installé
libapache2-mod-auth-kerb : Dépend: apache2-api-20120211
lib.........

toute la collection libapache.

j'ai tenté un apt-get -f install --> nok
un apt-get install --fix-missing --> nok


je suis vraiment dans la muise.

quelqu'un pour m'aider s'ils vous plais.


edit: il n'y a pas moyen de faire un "downgrade" pour tout remettre comme avant ???
« Last Edit: April 13, 2014, 10:35:26 pm by djnenex »

philippe

  • Zen Apprentice
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: !!! aidez-moi svpm !!! plantage pendant maj en 3.4
« Reply #1 on: April 14, 2014, 03:26:03 pm »
Je ne connais pas encore bien Zentyal. Mais j'ai déjà eu plusieurs fois le même problème sous Ubuntu.

Pour résoudre ces problèmes de dépendances. Il faut :
- soit attendre la prochaine mise à jour des dépôts. Les informations de dépendances n'étant peut-être pas correctes lorsque tu as fait l'apt-get update.
- soit résoudre toi-même les problèmes de dépendances. Par exemple, en installant à la main, le paquet manquant. Par exemple avec : apt-get install apache2

djnenex

  • Zen Apprentice
  • *
  • Posts: 14
  • Karma: +0/-0
    • View Profile
Re: !!! aidez-moi svpm !!! plantage pendant maj en 3.4
« Reply #2 on: April 14, 2014, 04:50:57 pm »
bonjour sampont, deja merci de ta reponse, hélas j'ai deja essayé de l'installer a la main, sans succés.
je pense que je vais tout sauvegarder en externe (pfff, 2To ça fait du volume) casser entierement le serveur et refaire une install fraiche en 3.4 .

je reste a l'écoute de solutions moins radicales, de plus je ne suis peut-etre pas le seul dans ce cas.
« Last Edit: April 14, 2014, 06:02:03 pm by djnenex »

philippe

  • Zen Apprentice
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: !!! aidez-moi svpm !!! plantage pendant maj en 3.4
« Reply #3 on: April 15, 2014, 09:03:44 am »
Deux autres solutions peut-être :

- Essaie avec le logiciel aptitude au lieu de apt-get. Apitude saura peut-être mieux gérer les dépendances et te proposera des solutions. : aptitude install apache2
- Sinon, au lieu de tout réinstaller, essaie plutôt de désinstaller apache2 (avec apt-get remove apache2) et puis de le réinstaller (apt-get install apache2)

djnenex

  • Zen Apprentice
  • *
  • Posts: 14
  • Karma: +0/-0
    • View Profile
Re: !!! aidez-moi svpm !!! plantage pendant maj en 3.4
« Reply #4 on: April 17, 2014, 05:35:49 pm »
bonjour philippe, hélas aptitude ne peut rien pour moi non plus, merci pour cette piste en tout cas.

le probleme vas etre solutionné, je termine mes sauvegardes et je refait entierement le serveur, comme ça pas de truc bancale avec des risques de failles de sécu.

merci a ceux qui on répondu.