Author Topic: Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready  (Read 18071 times)

StuartNaylor

  • Guest
Re: Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready
« Reply #45 on: April 17, 2014, 06:30:14 am »
Look guys I downloaded 3.3 set up a very basic server dns, dhcp, ntp and networking.

Then ran the upgrade after updating to 3.3.9 ?

Anyway it works and eventually there is an upgrade script.

You need to look at your repo's in /etc/apt/sources.list

Code: [Select]
deb http://archive.zentyal.org/zentyal 3.3 main extra for 3.3

Code: [Select]
deb http://archive.zentyal.org/zentyal 3.4 main extra for 3.4

The ppa has been moved, killed or has gone into hiding its a ppa a temp dev repo.

So there is some legacy junk with repo's to sort out before you upgrade.

Maybe the script could include this.

Also zentyal when it comes to scripts and repo control there is a subfolder sources.list.d that is included into the apt scope.

I hate trying to create sed text manipulations make things easy for yourself and maybe use it and separate config files.

Again I am not having a go but why does Zentyal keep using that god damn awful registry aka redis.
Why do we need a high performance database such as redis for configuration.

It creates a barrier for bug checking, when you have perfectly good /etc config files that are generally the defacto way of configuration why does Zentyal believe its more clever than Linus?

Why do it?

Smites from the team that make this perfectly working piece of software. :)


Well I won't add anything else to this. I thing that I have exposed all that I needed to. The broader views you have DO NOT refer to open sourcing, but to different ways on which a community is build, and that is not  something I'm going to discuss about.

Open Source is what what have been speaking about, guess that you do not consider your self cleverer that Stallman, do you?

Period

   

« Last Edit: April 17, 2014, 09:52:19 am by StuartNaylor »

JPB

  • Zen Monk
  • **
  • Posts: 77
  • Karma: +1/-1
    • View Profile
Zentyal upgrade failed
« Reply #46 on: April 17, 2014, 10:33:24 am »
Error log show these after Upgrade was pressed and it went through it all

Code: [Select]
Errors were encountered while processing:
 suricata
 zentyal-ips

Zentyal upgrade failed. Full log at /var/log/zentyal/upgrade.log.

I also found this error running apt-get update
Code: [Select]
W: Failed to fetch http://ppa.launchpad.net/zentyal/3.4/ubuntu/dists/saucy/main/binary-amd64/Packages  404  Not Found

W: Failed to fetch http://ppa.launchpad.net/zentyal/3.4/ubuntu/dists/saucy/main/binary-i386/Packages  404  Not Found

robb

  • Guest
Re: Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready
« Reply #47 on: April 17, 2014, 10:42:09 am »
I just browsed through the repo and the 3.4 branch is not there: http://ppa.launchpad.net/zentyal/

JPB

  • Zen Monk
  • **
  • Posts: 77
  • Karma: +1/-1
    • View Profile
Re: Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready
« Reply #48 on: April 17, 2014, 10:46:19 am »
I just browsed through the repo and the 3.4 branch is not there: http://ppa.launchpad.net/zentyal/

It seem like they dropped the ppa.launchpad but did not include edit for it in the /etc/apt/sources.list edit in the upgrade script. It did add the line
Code: [Select]
deb http://archive.zentyal.org/zentyal 3.4 main extraLooks like it supersede the ppa I did a rem # on that line and ran the update again - holding thumbs!

JPB

  • Zen Monk
  • **
  • Posts: 77
  • Karma: +1/-1
    • View Profile
BIG mess!!!
« Reply #49 on: April 17, 2014, 10:52:01 am »
After making the edit above in prev post and running apt-get update && apt-get upgrade results in:
Code: [Select]
...
...
...
Extracting templates from packages: 96%E: Could not open file descriptor -1
E: Prior errors apply to /var/cache/apt/archives/libdatetime-locale-perl_1%3a0.45-2_all.deb
E: Prior errors apply to /var/cache/apt/archives/libdatetime-perl_2%3a1.03-1_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/libfm-data_1.1.2-0ubuntu1_all.deb
E: Prior errors apply to /var/cache/apt/archives/libfm-gtk-data_1.1.2-0ubuntu1_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/libpam-ldap_184-8.5ubuntu3_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/libtommath0_0.42.0-1build1_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/mtr_0.85-1_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/python-tz_2012c-1_all.deb
debconf: apt-extracttemplates failed: No such file or directory
Extracting templates from packages: 100%
Setting up bash (4.2-5ubuntu3) ...
Installing new version of config file /etc/bash.bashrc ...
Installing new version of config file /etc/skel/.bashrc ...
update-alternatives: using /usr/share/man/man7/bash-builtins.7.gz to provide /usr/share/man/man7/builtins.7.gz (builtins.7.gz) in auto mode
(Reading database ... 335809 files and directories currently installed.)
Preparing to replace suricata 1.1.1-1 (using .../suricata_1.4.3-1_amd64.deb) ...
 * NFQUEUE support not found !
 * Please ensure the nfnetlink_queue module is loaded or built in kernel
invoke-rc.d: initscript suricata, action "stop" failed.
dpkg: warning: subprocess old pre-removal script returned error exit status 5
dpkg: trying script from the new package instead ...
 * NFQUEUE support not found !
 * Please ensure the nfnetlink_queue module is loaded or built in kernel
invoke-rc.d: initscript suricata, action "stop" failed.
dpkg: error processing /var/cache/apt/archives/suricata_1.4.3-1_amd64.deb (--unpack):
 subprocess new pre-removal script returned error exit status 5
 * NFQUEUE support not found !
 * Please ensure the nfnetlink_queue module is loaded or built in kernel
invoke-rc.d: initscript suricata, action "start" failed.
dpkg: error while cleaning up:
 subprocess installed post-installation script returned error exit status 5
Preparing to replace dash 0.5.7-2ubuntu2 (using .../dash_0.5.7-3ubuntu1_amd64.deb) ...
Unpacking replacement dash ...
Processing triggers for man-db ...
Errors were encountered while processing:
 /var/cache/apt/archives/suricata_1.4.3-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

JPB

  • Zen Monk
  • **
  • Posts: 77
  • Karma: +1/-1
    • View Profile
[SOLVED]
« Reply #50 on: April 17, 2014, 12:35:24 pm »
I found a Solution on http://ubuntuforums.org/showthread.php?t=1608698 thanx to  matt_symes
Quote
There is a way to manually remove a package from dpkg.
This is assuming you have tried _all_ other methods.
i.e Purging and removing the package from dpkg.

As unless you know what you are doing you can do serious damage. If you want to be sure, it might be worth trying it in a VM first.
And make a backup the /var/lib/dpkg directory. I dont want to break your setup. Use at your own risk. Also i used this under debian.

1. dpkg -P suricata

If this does not work

2. dpkg -L suricata

This will list the files that suricatauses.

Navigate to.

3. /var/lib/dpkg/info

Delete the file.

4. suricata.postrm

Run

5. apt-get remove --purge suricata

Remove all files and directories you found with dpkg -L  <<<---Careful don't delete directories only files!!

Then run

6. apt-get update.

Kind regards.

BrunovonTroba

  • Zen Monk
  • **
  • Posts: 59
  • Karma: +2/-0
    • View Profile
Re: Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready
« Reply #51 on: April 17, 2014, 04:10:33 pm »
Illunis, chill slightly as I am not Zentyal staff or anyway connected.

Also considering I am dodging 3.4 but spent the time finding the answer for you, please I am only small :)

Code: [Select]
sudo sh /var/share/zentyal/upgrade-to-3.4
Its not powershell with a CLI added to a GUI

Its linux that is a CLI with a GUI.

Also to be honest most servers are dropping the whole GUI through security and loading reasons.

Run the above. Sorry there isn't a button.

I do understand your concerns and so do many others. So without this getting into another smite feast.

Tell me how the upgrade went as that might be another part of the story.
Sorry, does not work.
After complete upgrade and restart can't acces to Zentyal console - says "Waiting until Zentyal is ready" endlessly... (when connected to port 443)
Normally i am using port other than 443 to manage - this port is inaccessible.
And /etc/init.d/zentyal restart gives nothing. Not even a message

I have written it in other posts: DURING UPGRADE DELETE OLD FIREWALL RULE ADDED AUTOMATICALLY TO WEBADMIN - it collides with new differently named rule. User is not able to delete this rule manually.
Or there is another than administration page way to delete it???
I have made upgrade to 3.4 manually by installing fresh 3.4 version AND NOT SETTING WEBADMIN PORT TO OTHER THAN 443, importing configuration from 3.3. But in this case i can't use the old administration port from version 3.3 to access.
If Your Z3.3 is using port 443 to administer, change it in 3.4 to another one before importing configuration from 3.3

shaqan

  • Zen Apprentice
  • *
  • Posts: 14
  • Karma: +0/-0
    • View Profile
Re: Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready
« Reply #52 on: April 17, 2014, 06:22:14 pm »
Had only Zentyal 3.0 cd from old times. Installed it and step-by-step upgraded it to 3.4. Worked like a charm, though the process itself was lengthy

Roman Pavlyk

  • Zen Apprentice
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready
« Reply #53 on: April 18, 2014, 02:21:29 am »
SUCCESSFUL update

So i have also attempted the upgrade, as i feared it all went to hell , yet somehow I managed to get everything on-line . So for a sake of record im gone post my bash history since the moment i run the upgrade script , hopefully it helps those in trouble. It looks like the upgrade script has a broken upgrade sequence where some package were updated before their dependencies. But do judge for yourself.

BrunovonTroba

  • Zen Monk
  • **
  • Posts: 59
  • Karma: +2/-0
    • View Profile
Re: Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready
« Reply #54 on: April 18, 2014, 10:58:53 am »
Had only Zentyal 3.0 cd from old times. Installed it and step-by-step upgraded it to 3.4. Worked like a charm, though the process itself was lengthy
So it looks that there is a problem upgrading from 3.3 to 3.4

shaqan

  • Zen Apprentice
  • *
  • Posts: 14
  • Karma: +0/-0
    • View Profile
Re: Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready
« Reply #55 on: April 26, 2014, 02:00:48 pm »
Had only Zentyal 3.0 cd from old times. Installed it and step-by-step upgraded it to 3.4. Worked like a charm, though the process itself was lengthy
So it looks that there is a problem upgrading from 3.3 to 3.4

maybe, maybe not. It went like 3.0->3.1->3.2 (or was it straight 3.2 from 3.0?)->3.3->3.4, with reboots between each upgrade
Later, I tried straight 3.4 install and it would'nt recognize USB keyboard past GRUB
« Last Edit: April 26, 2014, 02:03:13 pm by shaqan »

pcready.cl

  • Zen Samurai
  • ****
  • Posts: 279
  • Karma: +13/-1
  • Zentyal Installer in Chile
    • View Profile
    • PC Ready Chile E.I.R.L.
Re: Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready
« Reply #56 on: July 21, 2014, 06:16:17 am »
will be available when upgrading from 3.4 to 3.5?
Carlos Gallardo I.
Jefe de Proyectos Informáticos
Email: cgallardo@pcready.cl
Telefono: (+56 2) 2938 1407
Telefono: (+56 32) 314 0883
Skype: pcready.cl
Facebook: pcreadychile
Twitter: @pcready_cl
Web: www.pcready.cl

J. A. Calvo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1985
  • Karma: +66/-2
    • View Profile
    • http://blogs.zentyal.org/jacalvo
Re: Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready
« Reply #57 on: July 22, 2014, 02:19:37 pm »
will be available when upgrading from 3.4 to 3.5?

very soon, probably this week :)
Zentyal Server Lead Developer

pcready.cl

  • Zen Samurai
  • ****
  • Posts: 279
  • Karma: +13/-1
  • Zentyal Installer in Chile
    • View Profile
    • PC Ready Chile E.I.R.L.
Re: Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready
« Reply #58 on: July 22, 2014, 06:05:55 pm »
will be available when upgrading from 3.4 to 3.5?

very soon, probably this week :)

Thanks!
Carlos Gallardo I.
Jefe de Proyectos Informáticos
Email: cgallardo@pcready.cl
Telefono: (+56 2) 2938 1407
Telefono: (+56 32) 314 0883
Skype: pcready.cl
Facebook: pcreadychile
Twitter: @pcready_cl
Web: www.pcready.cl

 

mailcat