Author Topic: Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready  (Read 18080 times)

markus.leitold

  • Zen Apprentice
  • *
  • Posts: 1
  • Karma: +1/-0
    • View Profile
Re: Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready
« Reply #15 on: April 15, 2014, 07:42:29 am »
For all of you who are using Zarafa as main Mail / Calendar / Contacts Application:

As it is NOT CLEARLY mentioned somewhere in the docs, not even in ChangeLogs:

!!Zentyal has COMPLETELY DROPPED ZARAFA in this release as Zarafa does not provide Packages for Ubuntus non-LTS releases!!

Yesterday I was surprised and shocked that my complete EMail / Calendar / Contacts Infrastructure incl. ActiveSync stopped working after upgrading to Zentyal 3.4, so now I have to revert back to 3.3 and hope I get my Zarafa Stores up and running again.

@ZentyalStaff: IMHO this should be announced more clearly, it es even NOT mentioned in the ChangeLogs! What are the future plans for Zarafa? Will this completely be removed and changed to OpenChange? Are there any migration plans for current Installations running Zarafa to Openchange?

StuartNaylor

  • Guest
Re: Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready
« Reply #16 on: April 15, 2014, 09:56:33 am »
I don't think it was actually planned.

Zarafa only supply for LTS.

Then I think the Zentyal crew ran into dependency hell as Zarafa and Openchange clashed. As compiling for saucy was the option.

I think in the next release which will be a LTS Zarafa will be back alongside Openchange.

Part of their development strategy is to release often and follow the ubuntu releases so each new LTS doesn't turn into a car crash.

Guess you will have to be patient or stay with what you had.

What I wish and its not that I am saying in anyway Zentyal are wrong. I just feel it would actually save a lot of angst if all this was explained.

The download page and community release from my point of view looks like a stable full working product.

I don't think it would detract to have an important readme that explains about release policies a little more.

Bored of saying this to be honest.
« Last Edit: April 15, 2014, 09:58:36 am by StuartNaylor »

illunis

  • Guest
Re: Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready
« Reply #17 on: April 15, 2014, 10:07:53 am »
i am doing several tests and one was to simply click on the X button where is says to upgrade to 3.4

OK...HOW do i bring it back?

thnx

StuartNaylor

  • Guest
Re: Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready
« Reply #18 on: April 15, 2014, 10:22:12 am »
I am not all that sure and actually if you should of been able to.

I mean obviously you could be 3.4 is supposed to be run on saucy which should require a dist-upgrade before hand.

So really that upgrade button should of been greyed out.

I guess you will have to do each of the zentyal modules installed.

apt-get install pkg=version version = previous version.

I have done this on other software but there are quite a few packages from zentyal.

Also your /etc/apt/sources.list will need to revert back to 3.3.

Might be sort that out just purge and reinstall. Thing is you have all your users and stuff.

So actually I will stop there , dunno.

This is generally why I think more of a warning with upgrades and releases would be a much easier and less painful path.

I never upgrade to be honest its always a reinstall and bring back data (users and files + config)

Also I might be unusual as a sysadmin but be it SBS or Zentyal I have never done an upgrade without having a working copy on another piece of hardware.

I know it should work and the Zentyal info is a bit shoddy, but guys if your system is critical then doh!
« Last Edit: April 15, 2014, 10:29:09 am by StuartNaylor »

illunis

  • Guest
Re: Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready
« Reply #19 on: April 15, 2014, 10:27:43 am »
to make it clearer

i have several servers running as tests and i am playing around...i have already upgraded to 3.4 some and it worked fine.

BUT

now i had another one that i wanted to upgrade later. So i simply CLOSED the button UPGRADE TO 3.4...There should be a way to bring it back....!

StuartNaylor

  • Guest
Re: Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready
« Reply #20 on: April 15, 2014, 10:32:19 am »
Apols changing /etc/apt-sources.list and forcing an install.

Got a horrid feeling it might blast any users in samba.

I can't say as I just wouldn't try, my reaction would be several grunts, a sigh and a reinstall.

Not really sure how you close a button though.

« Last Edit: April 15, 2014, 10:34:25 am by StuartNaylor »

illunis

  • Guest
Re: Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready
« Reply #21 on: April 15, 2014, 10:33:53 am »
Thanks...but i cannot accept that

There has to be a way to show the button AGAIN !

waiting for official answer !

StuartNaylor

  • Guest
Re: Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready
« Reply #22 on: April 15, 2014, 10:36:09 am »
I thought you where still trying to go back.

Change etc/apt/sources.list to the 3.4 repo. I guess.

But you should be on saucy not 12.04

illunis

  • Guest
Re: Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready
« Reply #23 on: April 15, 2014, 10:37:53 am »
no...its very simple.

I am at 3.3.9....i CLOSED the BUTTON --> UPGRADE TO 3.4

HOW DO I BRING IT BACK?

Simple....should be at least !

StuartNaylor

  • Guest
Re: Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready
« Reply #24 on: April 15, 2014, 10:42:04 am »
Probably is, somewhere.

Dunno, sort of stayed clear from 3.4 as the mail thing isn't good enough for me.

Also by not doing upgrades I am blind. But from forum history I thought the upgrade just upgraded the zentyal modules.

3.4 is based on 13.10 and I thought it was all chicken and egg unless that has now been fixed.

I am sure one of the Zentyal people will tell you.

Apt-get dist-upgrade to 13.10

nano /etc/apt/sources.list change all entries from 3.3 to 3.4

apt-get upgrade will prob do what that button should of done.
« Last Edit: April 15, 2014, 10:45:07 am by StuartNaylor »

illunis

  • Guest
Re: Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready
« Reply #25 on: April 15, 2014, 10:44:47 am »
I agree....but since they provide this button to simplify the process i want to believe that this button should be available all the time till u decide to upgrade and not just disappear when u close it.

lets see !

BrunovonTroba

  • Zen Monk
  • **
  • Posts: 59
  • Karma: +2/-0
    • View Profile
Re: Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready
« Reply #26 on: April 16, 2014, 12:02:53 am »
I have had this button, but after upgrade to 3.3.9 disappeared mysteriously

Probably is, somewhere.

Dunno, sort of stayed clear from 3.4 as the mail thing isn't good enough for me.

Also by not doing upgrades I am blind. But from forum history I thought the upgrade just upgraded the zentyal modules.

3.4 is based on 13.10 and I thought it was all chicken and egg unless that has now been fixed.

I am sure one of the Zentyal people will tell you.

Apt-get dist-upgrade to 13.10

nano /etc/apt/sources.list change all entries from 3.3 to 3.4

apt-get upgrade will prob do what that button should of done.
Checked - not possible
That is because automatic firewall rule for Zentyal Administration has changed name and is not properly replacing old rule

steffenromeiss

  • Zen Apprentice
  • *
  • Posts: 16
  • Karma: +0/-0
    • View Profile
Re: Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready
« Reply #27 on: April 16, 2014, 01:52:19 am »
I will do the same... 5 hours lost... I'm frustrated

steffenromeiss

  • Zen Apprentice
  • *
  • Posts: 16
  • Karma: +0/-0
    • View Profile
Re: Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready
« Reply #28 on: April 16, 2014, 02:02:18 am »
Fresh install...3.4

initial software installation failed
terminal does not work at all
vm is stuck again

it was working until I upgraded to 3.4

my test 3.4 install from yesterday does not work any more, i guess it's a broken update

StuartNaylor

  • Guest
Re: Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready
« Reply #29 on: April 16, 2014, 04:24:08 am »
OK here is the upgrade script.

Code: [Select]
#!/bin/bash

UPGRADE_FILE=/var/lib/zentyal/.upgrade-finished

rm -f $UPGRADE_FILE

export DEBIAN_FRONTEND=noninteractive

function upgrade
{
    apt-get update

    for i in `seq 1 10`
    do
        if apt-get dist-upgrade -y --force-yes --download-only
        then
            break
        else
            echo "Download failed, retrying in 5 seconds..."
            sleep 5
        fi
    done

    apt-get dist-upgrade -y --force-yes -o DPkg::Options::="--force-confdef"
}

sed -i "s/^deb-src/#deb-src/g" /etc/apt/sources.list

echo; echo "Upgrading your current system to the latest packages..."; echo
upgrade

# Stop modules to avoid conflicts in listening ports with haproxy
for module in usercorner captiveportal webserver
do
    service zentyal $module stop > /dev/null 2>&1
done

# Copy samba data to new destination and re-create hardlinks
if dpkg -l | grep -q zentyal-samba
then
    service zentyal samba stop
    pkill -9 samba
    pkill -9 smbd
    mkdir -p /var/lib/samba
    cp -r /opt/samba4/private /var/lib/samba/
    cp -r /opt/samba4/var/locks/* /var/lib/samba/
    ln -f /var/lib/samba/private/sam.ldb.d/DC*FORESTDNSZONES* /var/lib/samba/private/dns/sam.ldb.d/
    ln -f /var/lib/samba/private/sam.ldb.d/DC*DOMAINDNSZONES* /var/lib/samba/private/dns/sam.ldb.d/
    ln -f /var/lib/samba/private/sam.ldb.d/metadata.tdb /var/lib/samba/private/dns/sam.ldb.d/
    chown -R root:bind /var/lib/samba/private/dns
    chmod -R g+rw /var/lib/samba/private/dns
    service zentyal samba restart
fi

PRINTERS_INSTALLED="no"
if dpkg -l | grep -q zentyal-printers
then
    PRINTERS_INSTALLED="yes"
    apt-get remove -y --force-yes cups-common
fi

echo; echo "Upgrading from Ubuntu 12.04 to 13.10 with Zentyal 3.4..."; echo
sed -i 's/precise/saucy/g' /etc/apt/sources.list
sed -ri 's/zentyal(.)3.3/zentyal\13.4/g' /etc/apt/sources.list
upgrade

echo; echo "Forcing pending packages installation..."; echo
rm -f /var/lib/dpkg/info/freeradius-ldap.postinst
for i in users remoteservices
do
    sed -i '/initial-setup/d' /var/lib/dpkg/info/zentyal-${i}.postinst > /dev/null 2>&1
done
apt-get -f install -y --force-yes -o DPkg::Options::="--force-confdef"

pkill -9 samba
pkill -9 smbd
service zentyal samba restart > /dev/null 2>&1

if dpkg --configure -a --force-confdef
then
    if [ "$PRINTERS_INSTALLED" == "yes" ]
    then
        apt-get install -y --force-yes -o DPkg::Options::="--force-confold" zentyal-printers
    fi

    /usr/share/zentyal/global-action --action saveAllModules
    for i in users remoteservices
    do
        /usr/share/zentyal/initial-setup $i 3.3 > /dev/null 2>&1
    done
    service zentyal users restart > /dev/null 2>&1
    service zentyal webadmin restart
    service zentyal haproxy restart

    echo; echo "Zentyal upgrade finished!"

    rm -f /var/crash/_usr_sbin_samba*
    apt-get clean
else
    echo; echo "Zentyal upgrade failed. Full log at /var/log/zentyal/upgrade.log."
fi

touch $UPGRADE_FILE


After much farting about searching through Zentyal java scripts, deleting cookies and generally getting frustrated.
I think its a json / ajax variable that is client server orientated  and basically the answer is you can't

The script is in /usr/share/zentyal so run it from sudo.
« Last Edit: April 16, 2014, 06:44:08 am by StuartNaylor »